Register Login
FIAT Auto Specialist Team
Reply
 
Thread Tools
Old 04-10-2010   #1
The Ratter
 
slugworth1987's Avatar
Join Date: Oct 2010
Location: worksop, notts
Posts: 968
Thanks: 10
Trader Rating: 0
slugworth1987 has donated!
United Kingdom 
pre-mot checking and issues

hey all

now my L reg 1994 cinqi is going for its mot in 2 weeks its been off the road for 2 years and had a lil tlc but still has issues,

apart from the bad tappet noise and no rear washer power and the rubber bits off the suspension has fallen out slightly on the bottem part of the piston fwd l/h shocker.

the injection light is on from start i have disconnected the sensor on the fwd section of the engine i dont know if its the o2 sensor or something else i dont know much about cars as i have owned and maintained carbareted motorbikes
for the last 5 years lol!!!

also the side indicators are kinda intamitant with new bulbs in i think the connectors are a lil corroded

she needs a service and the exhaust seems to be stuttering a lil bit.

all advice will be noted i have been searching alot on the forum but not really found my problems on here lol.

pics will also help as i dont have a manual.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

slugworth1987 is offline Reply With Quote Quote 
Old 04-10-2010   #2
Autotest Special
 
rallycinq's Avatar
Join Date: Mar 2002
Posts: 23,444
Thanks: 1146
Blog Entries: 3
Trader Rating: 1
rallycinq has donated!
British Indian Ocean Territories 
Re: pre-mot checking and issues

Don't leave any sensors disconnected. Connect them all up and carry out checks against the nominals.

If the light is on from cold, its not the O2 sensor, that doesn't come into play until its warm.

Buy a manual, they ain't expensive, I prefer the porters one.

Cheers

D
__________________
rallycinq is offline Reply With Quote Quote 
Old 05-10-2010   #3
The Ratter
 
slugworth1987's Avatar
Join Date: Oct 2010
Location: worksop, notts
Posts: 968
Thanks: 10
Trader Rating: 0
slugworth1987 has donated!
United Kingdom 
Re: pre-mot checking and issues

ok well regarding the light, i have reconnected all wires, let the car warm up from cold on idle and no joy still on,

ran redex through it incase something was stuck in an injector, no joy, erm i have removed and cleaned the o2 sensor and no joy

as for the other issues.... no joy lol
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

slugworth1987 is offline Reply With Quote Quote 
Old 05-10-2010   #4
Autotest Special
 
rallycinq's Avatar
Join Date: Mar 2002
Posts: 23,444
Thanks: 1146
Blog Entries: 3
Trader Rating: 1
rallycinq has donated!
British Indian Ocean Territories 
Re: pre-mot checking and issues

So check the sensors against the nominals as a start.

Repeaters, yup corrosion. Pop them out and clean them up.

Don't understand what rubber bit has fallen out of the suspension.

Washer problem, if the motor is working, replace the non return valve.

Cheers

D
__________________
rallycinq is offline Reply With Quote Quote 
Old 06-10-2010   #5
The Ratter
 
slugworth1987's Avatar
Join Date: Oct 2010
Location: worksop, notts
Posts: 968
Thanks: 10
Trader Rating: 0
slugworth1987 has donated!
United Kingdom 
Re: pre-mot checking and issues

Quote Quote:
So check the sensors against the nominals as a
start.
erm... they are?

I have no idea about these fangled ecu condoobys carbs ftw lol

repeaters work yay!!!!!

suspension I pushed em back in....

washers removed valve and front washer 100% back spray no life....
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

slugworth1987 is offline Reply With Quote Quote 
Old 06-10-2010   #6
Autotest Special
 
rallycinq's Avatar
Join Date: Mar 2002
Posts: 23,444
Thanks: 1146
Blog Entries: 3
Trader Rating: 1
rallycinq has donated!
British Indian Ocean Territories 
Re: pre-mot checking and issues

Swap plugs on washer motors to check whether its the motor or wiring.

You are looking for resistances on the sensor. Each sensor has a nominal value, that if wrong, will upset the management system.

Use a meter to check each sensor in turn.

Cheers

D
__________________
rallycinq is offline Reply With Quote Quote 
Old 11-10-2010   #7
The Ratter
 
slugworth1987's Avatar
Join Date: Oct 2010
Location: worksop, notts
Posts: 968
Thanks: 10
Trader Rating: 0
slugworth1987 has donated!
United Kingdom 
Re: pre-mot checking and issues

hey sorry about the delayed post ive been working myself daft on overtime.

anyway i found out the battery was kerplunked.... cost me 70 for a new one!

MOT today... pass :-)

the rubber bits looked like dust covers but where cut off by the MOT guy saying i dont need em lol.

the car has 7 adviserys and erm 1 potential failer but the guy was so nice he let me off... i had a numberplate bulb out...

adviserys are.

1) Engine and gearbox have oil over them from either the had gasket or oil filter area as he said.

2 & 3)l/h & r/h fwd brake hoese detriated

4) rear bumper insecure on one side

5 & 6) l/h & r/h rear of drums corroded spotted no holes

7) rear bumper r/h bracket heavly corroded & holes.

not bad..

after 27 miles of driving my problem with the injector light is off... just after i had the batt fitted and alt tested.

now i have noticed the dash/vents rattle buzz and make loads of noise above 40mph, a squeak from the l/h brake or wheel i dunno not bearings as its nice and secure lol.

l/h speaker not working and stereo doesnt pick up radios on UHF lol

bloody money pit this thing lol
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

slugworth1987 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) Failed 1st ever MOT due to brake caliper and other issues dannyboy83 Grande Punto 3 19-06-2010 00:23
(T) hmmmmmm, emissions, pre-mot help mzhussein Punto (Mk2/2b) 22 15-11-2008 02:29
(G) Pre MOT checks?? lights, reccomendations etc mzhussein Punto (Mk2/2b) 13 07-10-2008 23:54
pre pre donny clean kayl0rz Car Care 15 08-04-2008 17:56
(G) For Information: Brava rear brake light MOT issues The Negotiator Bravo / Brava 9 25-06-2007 14:05