Register Login
Save up to 15% with Adrian Flux insurance!
Reply
 
Thread Tools
Old 23-06-2015   #1
Join Date: Dec 2013
Location: Johannesburg
Posts: 9
Thanks: 0
Trader Rating: 0
South Africa 
Electrical Issue

Hi all. The airbag light has come on the cluster, and at the same time the seatbelt warning on the cluster and alarm have stopped working. The Odo now also flashes all the time. I've hooked it up to a diagnostics machine but no faults are logged. Any suggestions as to where to look?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Kevin Reichert is offline Reply With Quote Quote 
Old 23-06-2015   #2
Join Date: May 2014
Location: Pretoria
Posts: 209
Thanks: 19
Trader Rating: 0
South Africa 
Re: Electrical Issue

Flashing odo means an electrical fault. Took my Blue&Me out and it flashes.
But also it could just be a simple ECU malfunction. Disconnect the battery for about 4 hours and it should reset the ECUs, worked with a friend of mine's Bravo

P.S. It's a proxy alignment failure, usually resetting this with the proper OBD software will fix the issue, but disconnecting the battery is the easier way out if you don't have all the tools
__________________
Olivia the 2011 Maranello Rosso Bravo T-jet Sport 150
l3v1athan is offline Reply With Quote Quote 
Old 30-06-2015   #3
Speed Reader of the Year!
 
Most Easterly Pandas's Avatar
Join Date: Aug 2007
Posts: 39,314
Thanks: 1231
Trader Rating: 2
Most Easterly Pandas has donated!
United Kingdom 
Re: Electrical Issue

Quote Originally Posted by l3v1athan View Post
Flashing odo means an electrical fault.
No, it means a node hasn't been detected that the body computer is looking for, or its found and extra one it wasn't looking for.

TBH sounds like the airbag ECU, or some other ECU / connection / wiring may have had it
__________________
Most Easterly Panda's - Panda'ing in East Anglia
Stockest of mk2 Panda Parts, PM for any parts requests
1993 Classic Panda Selecta, 1989 Panda 750L,
2015 Kia Soul EV, 2009 Panda Eleganza & 2005 Panda Climbing 4x4 (LPG)
Most Easterly Pandas is offline Reply With Quote Quote 
Old 07-07-2015   #4
Join Date: Dec 2013
Location: Johannesburg
Posts: 9
Thanks: 0
Trader Rating: 0
South Africa 
Re: Electrical Issue

Hi all. Have tried all the solutions on offer and nothing seems to work? Took the car to Fiat and their diagnostics machine traces no errors, i have traced wiring from the seat sensors to the front mount impact sensor for the airbag with no joy. I did read that the body ECU is not finding one of the other ECU's but i dont know how to reset that issue.. any ideas?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Kevin Reichert is offline Reply With Quote Quote 
Old 07-07-2015   #5
Join Date: Dec 2005
Location: Glasgow
Posts: 317
Thanks: 15
Trader Rating: 0
United Kingdom 
Re: Electrical Issue

How old is the car battery? Tried charging it?
__________________
Bravo 1.9 mjet 150 Dynamic
Fergie is offline Reply With Quote Quote 
Old 07-07-2015   #6
flying low...
 
santa's Avatar
Join Date: Mar 2005
Location: Viborg, Jylland
Posts: 836
Thanks: 17
Trader Rating: 0
santa has donated!
Denmark 
Re: Electrical Issue

Quote Originally Posted by Kevin Reichert View Post
Hi all. The airbag light has come on the cluster, and at the same time the seatbelt warning on the cluster and alarm have stopped working. The Odo now also flashes all the time. I've hooked it up to a diagnostics machine but no faults are logged. Any suggestions as to where to look?
I have recently had the exact same error (except the alarm error, as it's not installed in my Bravo).
The error was casued by a faulty airbag ECU.
The garage couldn't get in contact with it via the ODB2 port, so they had to "dig" their way to it (it's located behind the centre console), when they got to it, it was dead.
So a new one was ordered and installed.....it's not cheap, by the way
__________________
2015 Mazda CX-3 2.0 120BHP Optimum Aut.
santa is offline Reply With Quote Quote 
Old 07-07-2015   #7
Join Date: Dec 2013
Location: Johannesburg
Posts: 9
Thanks: 0
Trader Rating: 0
South Africa 
Re: Electrical Issue

Hi Fergie. Its a new one..
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Kevin Reichert is offline Reply With Quote Quote 
Old 07-07-2015   #8
Speed Reader of the Year!
 
Most Easterly Pandas's Avatar
Join Date: Aug 2007
Posts: 39,314
Thanks: 1231
Trader Rating: 2
Most Easterly Pandas has donated!
United Kingdom 
Re: Electrical Issue

Quote Originally Posted by Kevin Reichert View Post
Hi Fergie. Its a new one..
Has this happened since it was replaced? Has the battery actually been put on a bench charger before fitting to the car?
__________________
Most Easterly Panda's - Panda'ing in East Anglia
Stockest of mk2 Panda Parts, PM for any parts requests
1993 Classic Panda Selecta, 1989 Panda 750L,
2015 Kia Soul EV, 2009 Panda Eleganza & 2005 Panda Climbing 4x4 (LPG)
Most Easterly Pandas is offline Reply With Quote Quote 
Old 07-07-2015   #9
Join Date: Dec 2013
Location: Johannesburg
Posts: 9
Thanks: 0
Trader Rating: 0
South Africa 
Re: Electrical Issue

Hey Santa. That does not sound good at all... Thanks for the advice, I will investigate further. (You dont have any ideas with regards to the oil heat exchanger leaking oil - i am searching for a replacment gasket but the agents only sell the oil filter unit with cooler as a complete unit :-(
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Kevin Reichert is offline Reply With Quote Quote 
Old 07-07-2015   #10
Join Date: Dec 2013
Location: Johannesburg
Posts: 9
Thanks: 0
Trader Rating: 0
South Africa 
Re: Electrical Issue

Hi. The battery was replaced after the issue took place..
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Kevin Reichert is offline Reply With Quote Quote 
Old 07-07-2015   #11
flying low...
 
santa's Avatar
Join Date: Mar 2005
Location: Viborg, Jylland
Posts: 836
Thanks: 17
Trader Rating: 0
santa has donated!
Denmark 
Re: Electrical Issue

Quote Originally Posted by Kevin Reichert View Post
Hey Santa. That does not sound good at all... Thanks for the advice, I will investigate further. (You dont have any ideas with regards to the oil heat exchanger leaking oil - i am searching for a replacment gasket but the agents only sell the oil filter unit with cooler as a complete unit :-(
No, sorry....I haven't any ideas for the oil heat exchanger.
You could try searching for an ECU from a wrecked car, that might be cheaper.
__________________
2015 Mazda CX-3 2.0 120BHP Optimum Aut.
santa is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Electrical issue. Steve1966F 500 (Classic) 4 22-04-2015 23:30
(T) Electrical Issue cardiffphil Grande Punto 2 20-03-2014 20:10
(T) New here and got an electrical issue! Pilp X1/9 6 07-01-2011 18:47
(T) Electrical issue brown bear Punto (Mk2/2b) 0 21-05-2009 17:52
Electrical Issue Dave FIAT Boo Archives 6 14-06-2008 11:28