Register Login
The UK's No.1 Chrysler Owners Forum
Reply
 
Thread Tools Search this Thread
Old 17-05-2011   #1
Join Date: Sep 2006
Location: Strood, Kent
Posts: 70
Thanks: 0
Trader Rating: 0
United Kingdom 
Loss of power during motorway driving

The car in question is a 1.9JTD.

After driving on the motorway for approx. 20mins or so i tend to loss some power (i.e. get stuck behind a slow car but am unable to gather enough speed to overtake until revs reach over 3000).

Originally i thought that it was after heavy breaking as i only noticed it when pulling away at traffic lights/roundabouts at the end of slip roads but it is now noticable when actually driving.

Any ideas anyone? I have to drive to Devon at the end of May and could do with fixing this problem (or i will have to borrow my dads Rover!).

Thanks in advance

Lee
__________________
2001 Fiat Bravo GT JTD, Broom Yellow! and 1999 Fiat Seicento Sporting, Silver!
lee_gti is offline Reply With Quote Quote 
Old 17-05-2011   #2
Telford's Own...
 
Ffoxy's Avatar
Join Date: Apr 2007
Posts: 9,824
Thanks: 373
Trader Rating: 0
Ffoxy has donated!
United Kingdom 
Re: Loss of power during motorway driving

Usual suspects are EGR or MAF sensor, plenty of Posts / Threads on those in here, try a search
__________________
Ex Suzuki SV1000S jockey, now a former 1.9 MJet Grande Punto Sporting pilot curently driving a Hyundai i30 1.6 Premium.
Ffoxy is offline Reply With Quote Quote 
Old 17-05-2011   #3
Join Date: Sep 2006
Location: Strood, Kent
Posts: 70
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Loss of power during motorway driving

Previously i had the MAF go but when that happened it was if the power stopped at 2500 revs.

The case is now that there is no power until 3000 revs making it extremely difficult to pull away from junctions, roundabouts etc during 20mins or so motorway journeys.

Lee
__________________
2001 Fiat Bravo GT JTD, Broom Yellow! and 1999 Fiat Seicento Sporting, Silver!

Last edited by lee_gti; 17-05-2011 at 13:32.
lee_gti is offline Reply With Quote Quote 
Old 19-05-2011   #4
Join Date: Sep 2006
Location: Strood, Kent
Posts: 70
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Loss of power during motorway driving

I have been reading through the forums and I am yet to find anyone with a problem that occurs after some driving. Mainly their problem occurs from the start.

How would i go about checking an EGR valve? (obviously I dont really want to drive around with a blocked valve (possibly causing damage) for a lenght of time before the current problem kicks in).

Any help/info will be appreciated.

Regards

Lee
__________________
2001 Fiat Bravo GT JTD, Broom Yellow! and 1999 Fiat Seicento Sporting, Silver!
lee_gti is offline Reply With Quote Quote 
Old 08-08-2011   #5
Join Date: Dec 2008
Location: Derbyshire
Posts: 5
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Loss of power during motorway driving

Hey lee_gti

I am having the same problem. And do u have to put into neutral and foot to floor on pedal untill it redlines?

My stilo is doing this from starting the car.

May have to change my altonator belt as its ready... Could this be the problem??

Baggaley88....
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Baggaley88 is offline Reply With Quote Quote 
Old 08-08-2011   #6
Join Date: Dec 2008
Location: Derbyshire
Posts: 5
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Loss of power during motorway driving

Also mate.. Ive had my EGR off and cleaned. Still the same problem though :-(

Mate of mine says my turbo could do with cleaning as the vains could be blocked...

Baggaley88...
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Baggaley88 is offline Reply With Quote Quote 
Old 17-08-2011   #7
Join Date: Sep 2007
Location: West Midlands
Posts: 87
Thanks: 0
Trader Rating: -1
mike_bravohgt has donated!
United Kingdom 
Re: Loss of power during motorway driving

Have you checked the lambda, air intake pipes for splits, or leaks in the exhaust before the lambda sensor? Having a similar prob with my hgt and I'm almost certain its the lambda sensor.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

mike_bravohgt is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) Power loss after 10 mins on motorway theictfacilitator Ulysse 1 06-03-2011 18:32
(G) Motorway driving pazzer Stilo 13 28-08-2007 18:49
Town or motorway driving, which is better in the long run Mcp138 Car Care 14 30-01-2007 20:12
(G) Jerking/ loss of power while driving fluffyowl0 Uno 10 05-03-2005 12:20
(G) Motorway Driving? Cinqsporting Cinquecento / Seicento 22 26-11-2003 17:34