Register Login
Mr FIAT - Your #1 source for vintage car parts
Reply
 
Thread Tools
Old 13-11-2007   #1
Join Date: Nov 2007
Posts: 2
Thanks: 0
Trader Rating: 0
Thumbs up Fiat Bravo 1.2 16v misfire problem.

My daughter has a Bravo 1.2 16v 80 car

it had developed a missfire the typical sort you get with petrol cars.

I have replaced the HT leads after taking it up the chase in the dark and looking at leads when reved up, i could see arc lights on the leads.

I thought this would resolve the issue but it still seems to be present.

when your pulling off you can feel it holding back then it goes ok somtimes worce then others.

it can become jerky to pull away somtimes.

Plugs where changed some months ago.

so plugs and leads i have ruled out to be honest.

Any sugestions would be good.


Rick
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Rickathome is offline Reply With Quote Quote 
Old 14-11-2007   #2
Join Date: Aug 2003
Location: Essex/Suffolk border
Posts: 82,509
Thanks: 1458
Trader Rating: 10
dave has donated!
dave is an official FF Advertiser
dave is an honorary friend of the forum :)
United Kingdom 
Re: Fiat Bravo 1.2 16v misfire problem.

Quote Originally Posted by Rickathome View Post
after taking it up the chase in the dark



have you tried a bottle of good quality (not redex) injector cleaner?
__________________
“The further a society drifts from the truth, the more it will hate those that speak it.”
dave is offline Reply With Quote Quote 
Old 14-11-2007   #3
Join Date: Nov 2007
Posts: 2
Thanks: 0
Trader Rating: 0
Thumbs up Re: Fiat Bravo 1.2 16v misfire problem.

I did put some in about 4 months ago but i am sure this seems electrical

I may be wrong.

If you rev it up it seems responsive and smooth but soon as it is under load it becomes more noticeable

__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Rickathome is offline Reply With Quote Quote 
Old 09-07-2009   #4
Join Date: Jun 2009
Posts: 9
Thanks: 0
Trader Rating: 0
Re: Fiat Bravo 1.2 16v misfire problem.

hi,
sorry to hear your in the same boat as myself,so far i`ve changed
plugs, leads, coil pack , knock sensor , cam sensor, crank sensor, cam belt and tensioner( just incase belt had gone slack and messed up the valve timing) and four injectors...improved it but not cured it....i will keep an eye on your thread if you do likewise and maybe one of us will beat this bloody problem....good luck
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

crgbrns is offline Reply With Quote Quote 
Old 09-07-2009   #5
Join Date: Mar 2005
Posts: 1,839
Thanks: 103
Trader Rating: 1
JoskeJTD has donated!
United Kingdom 
Re: Fiat Bravo 1.2 16v misfire problem.

This could be a number of things. Have any warning lights appeared at all? Basically what you described sounds like it could be at worse HG failure (common fault on 1.2) or the cambelt has jumped a tooth, best way would be to do a compression test, BUT I would definately look at the MAP sensor and Crankshaft sensor as any of these sensors can also cause a misfire and poor acceleration if not working correctly.

Some people have fixed similar problems by removing excess moisture from relays, fuses and the battery from the engine bay by using WD40, some have replaced the Lambda sensor but most commonly the MAP sensor or Crankshaft sensor is at fault. However i believe it would trigger a warning light if the MAP sensor was faulty, but maybe not. Probably worth a go if cheap enough.
__________________

Last edited by JoskeJTD; 09-07-2009 at 21:55.
JoskeJTD is offline Reply With Quote Quote 
Old 09-07-2009   #6
Speedbump grimacer
 
Adrian Bravo's Avatar
Join Date: Mar 2008
Location: North West
Posts: 4,425
Thanks: 184
Blog Entries: 3
Trader Rating: 1
Adrian Bravo has donated!
United Kingdom 
Re: Fiat Bravo 1.2 16v misfire problem.

crgbrns has thread about it here.
https://www.fiatforum.com/bravo-brav...-pls-help.html
Adrian Bravo is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) How many Puntos are there on the Forum? - The Thread FiatStiloJTD Punto (Mk2/2b) 543 06-06-2008 18:15