Register Login
FIAT Auto Specialist Team
Reply
 
Thread Tools
Old 08-04-2006   #1
Join Date: Nov 2004
Posts: 15
Thanks: 0
Trader Rating: 0
United Kingdom 
Question Fuel Pump (not working?)

Confused: I have just replaced two injectors on my 1.6 sx marea and upon restarting the engine ran for a couple of minutes and suddenly cut out. on checking the guage and fuel delivery i realised it had run out of fuel. I put a full can of fuel in and tried to restart, no go. i've checked the two thick rubber fuel pipes that supply the rail and they're both dry. I can hear the fuel pump when i turn on the ignition and it seems to be working. however the car will not start as there is no fuel being delivered. scratching my head wondering if level of fuel is still too low . Thanks Graham
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

jamgeo is offline Reply With Quote Quote 
Old 08-04-2006   #2
Status: DEFCON Grumpy
 
custard's Avatar
Join Date: Nov 2003
Location: Edinburgh
Posts: 30,129
Thanks: 495
Trader Rating: 1
custard has donated!
United Kingdom 
Re: Fuel Pump (not working?)

perhaps you should change the fuel filter.you may have sucked some crap out of the bottom of the tank.whgilst the filters out you can see if the pump brings fuel to the fuel filter pipe
custard is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) Panda Fuel Pump Question Steven Panda (Classic) 29 08-02-2008 20:04
(T) Fiat uno 1.1 ies fuel pump ayden Uno 16 31-10-2005 21:11
(T) fuel pump & spark plugs not working tjs Punto (Mk2/2b) 3 25-03-2005 20:30
(G) Panda Fuel Pump Steven Panda (Classic) 7 22-11-2004 08:35
(T) Seicento SX 01 - Fuel pump appears not to be running dimension3 Cinquecento / Seicento 3 02-09-2004 15:26