Register Login
Mr FIAT - Your #1 source for vintage car parts
Reply
 
Thread Tools Search this Thread
Old 26-07-2004   #1
Join Date: Apr 2003
Location: Honiton, United Kingdom.
Posts: 16
Thanks: 0
Trader Rating: 0
uno electrical problems

hi can anyone help i have a fiat uno 1100cc MK2 91J with a intermitant electrical fault that i am beating my head against brick wall i dont really know much about car electronics,problem is when car reaches normal running temp all the electrics cut out temp gauge goes off the scale radio cuts out head lights indicators engine cooling fan interior light when doors are left shut key out of ignition hand brake light glows then it can just return to normal then it may do it again, i have replaced fuse box and checked connection blocks etc.what do i do next?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

andy is offline Reply With Quote Quote 
Old 26-07-2004   #2
Status: DEFCON Grumpy
 
custard's Avatar
Join Date: Nov 2003
Location: Edinburgh
Posts: 30,129
Thanks: 495
Trader Rating: 1
custard has donated!
United Kingdom 
have you checked the bodywork earth connections, including the engine to body earth straps?

A Dog Is Not Just For Christmas
Sliced Thinly It Can Last Till Easter
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

custard is offline Reply With Quote Quote 
Old 27-07-2004   #3
Join Date: Jul 2004
Location: Watford
Posts: 7,329
Thanks: 238
Trader Rating: 0
Chas Uno has donated!
Air Dodge Champion, Asteroids2000 Champion, Frogger Champion
United Kingdom 
Could also be a faulty ignition switch. These can wear and give similar faults to those like you are experiencing. The contacts inside the switch, by that I mean the electric switch that bolts onto the ignition key barrel, can give intermittant connections and give similar symptons. Other than that, check the battery cables and the engine/ gearbox earth leads.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Chas Uno is offline Reply With Quote Quote 
Old 30-07-2004   #4
NobodyBlamesTheHappyGuy!
 
Morty Mort's Avatar
Join Date: Jun 2003
Location: 69 North
Posts: 2,831
Thanks: 135
Trader Rating: 2
Morty Mort has donated!
Norway 
When the car reaches 100 C the fan will cut in. It may be a fault here. Try to start the car and let it idle until the fan starts. If your car goes berzerk at this point, it may be it. Anyway it sounds like a good old Fiat earth problem. We had one on our Ritmo Abarth. There was an earth block with many wires attached, and it was rattling on the bodywork. Instruments etc. went crazy.

Morten.


gas lowered on abarth wheels. upgraded interior and visuals. audio through phoenix gold and kenwood. air through k&n.

projects: exhaust. rust removal.

Honey that ain't no pistol - that's my LOVE GUN.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Morty Mort is offline Reply With Quote Quote 
Old 11-08-2004   #5
Join Date: Dec 2003
Location: United Kingdom.
Posts: 8
Thanks: 0
Trader Rating: 0
Re: uno electrical problems

Ay up mate i had this happen to my old uno,it is the earth cable that goes from battery to the block or where ever,half way along its length it has the outer casing removed and is squashed into a crappy earth connection with loads of spades coming off it,chop all the old spades off and renew and clean big conector and grease it then clean main lead flux it and solder to old tag with heat gun and also run an earth lead back to battery for good measure.

Cheers paul
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

paul w is offline Reply With Quote Quote 
Old 10-12-2014   #6
Join Date: May 2014
Posts: 4
Thanks: 0
Trader Rating: 0
Portugal 
Re: uno electrical problems

I know it's been 10 years since this topic was touched: I have the exact same problem! When the car reaches normal running temp, electrical problems start: beam lights go weaker, radio turns off and on, and the temp gauge starts responding to electrical consuming (it goes up if I turn any thing electrical on).
Did you solve your problem? How?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

afonsopatrao is offline Reply With Quote Quote 
Old 18-02-2015   #7
Join Date: Feb 2015
Location: Wetton Cape Town
Posts: 2
Thanks: 0
Trader Rating: 0
South Africa 
Re: uno electrical problems

check your earth cable under the battery or and an extra earth from the negatve terminal to the body of your car
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Richard Africander is offline Reply With Quote Quote 
Old 26-02-2015   #8
Join Date: May 2014
Posts: 4
Thanks: 0
Trader Rating: 0
Portugal 
Re: uno electrical problems

Thank you so much!! Problem solved!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

afonsopatrao is offline Reply With Quote Quote 
Old 07-12-2017   #9
Join Date: Dec 2017
Posts: 1
Thanks: 0
Trader Rating: 0
South Africa 
Re: uno electrical problems

Hi how did u solve ur proplem i have same issue u had with my uno 1100
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Harold5881 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Electrical problems with my Tipo 1.7D (1993/4 'L') danny_bellis Tipo (Classic) 5 18-07-2004 18:48
(G) Electrical problems Splash9 Tipo (Classic) 4 16-03-2004 19:38
(T) stilo abarth electrical problems harrycat Stilo 12 17-02-2004 18:52
(T) Punto HGT Electrical Problems darren1974 Punto (Mk2/2b) 2 11-02-2004 04:05
(T) Electrical problems in rebuilding my 1.9 TD josh Tipo (Classic) 0 03-02-2003 15:41