Register Login
im Axle Specialists
Reply
 
Thread Tools
Old 14-07-2013   #1
Join Date: Apr 2013
Posts: 18
Thanks: 0
Trader Rating: 0
United Kingdom 
High Beam lights fault

Side and Main Beams work fine, but high beams only come on only after you've pulled the stalk back 40 or 50 times. Even when they're working, they sometimes go off after a while and another 50 pulls are required to get them on again.

I went to Desira, my local dealer and was informed that the headlight unit connector cables had been fitted incorrectly in the past and, this was causing the malfunction. Two new headlights were recommended for which they quoted 1348 fitted!!! Fortunately, I had a spare headlight (with broken fixings) and I tried that. Needless to say, it didn't make any difference.

I have changed the relays round. Still no difference.

Is there a control box between the stalk and the lights? Are there any diagnostic checks that can be made? in fact, ANY suggestions?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

taxi13 is offline Reply With Quote Quote 
Old 14-07-2013   #2
Join Date: Jan 2011
Posts: 141
Thanks: 9
Trader Rating: 0
United Kingdom 
Re: High Beam lights fault

If you search the Fiat forum or the Peugeot 807 forum you will find many reports of headlights, dipped beams, indicators, etc., operating erratically. This is usually due to a faulty COMM 2003 unit (the unit under the steering wheel) which looks like this: http://www.ebay.co.uk/itm/PEUGEOT-CITROEN-INDICATOR-WIPER-STALK-COMMS-UNIT-96611305XT-FREE-UK-POST-/281118219132?pt=UK_CarsParts_Vehicles_CarParts_SM& hash=item4173f39b7c

The exact version of this part which you may need varies according to the age of your car. If you enter your VIN number into ePER (Fiat parts catalogue on the blue menu at the top of this forum page) it will give you the correct part number for you car.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

avionista is offline Reply With Quote Quote 
Old 15-07-2013   #3
Join Date: Aug 2004
Posts: 531
Thanks: 14
Trader Rating: 0
United Kingdom 
Re: High Beam lights fault

The first thing I would do is simply try another stalk, there's plenty of these being scrapped now.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

FRANTIC FRAN is offline Reply With Quote Quote 
Old 15-07-2013   #4
Join Date: Apr 2013
Posts: 18
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: High Beam lights fault

I forgot to mention. I have a 2.0 diesel Ulysse Eleganza 2005.

I made a mistake. My garage did not change the relays, as they couldn't find any for the headlights. Is that correct, no relay? If so, I assume that the wiring must go straight from the comms unit to the lights. And therefore, there can't be anything wrong beyond the comms unit.

I've just been quoted 40 for a second hand comms unit. So I ordered it. I'll let you know in a few days time if it has worked.

In the mean time any other suggestions would be welcome
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

taxi13 is offline Reply With Quote Quote 
Old 08-08-2013   #5
Join Date: Apr 2013
Posts: 18
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: High Beam lights fault

Well I changed the coms unit as advised. It made no difference.

However, the lighting problems have now got a lot worse. I need more help.

When the ignition is on, but the engine is off. The situation is just as I described originally. But when you turn the engine on, and you select the main beams, all the lights (main, high and fog) come on dimly. Only the offside main beam is working normally. Nothing changes when you select the high beam. But strangest of all, when you select the fog lights the engine dies.

Any more advice?????????
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

taxi13 is offline Reply With Quote Quote 
Old 08-08-2013   #6
Join Date: Mar 2007
Location: Limerick
Posts: 1,644
Thanks: 59
Trader Rating: 0
Ireland 
Re: High Beam lights fault

Exactly as Fran said, change the stalk.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

digger58 is offline Reply With Quote Quote 
Old 08-08-2013   #7
Join Date: Apr 2013
Posts: 18
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: High Beam lights fault

I did!

The comms unit is the whole unit with all the stalks. So, I have already replaced the lot. Nothing changed apart from the 100 hole in my pocket.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

taxi13 is offline Reply With Quote Quote 
Old 09-08-2013   #8
Join Date: Feb 2012
Posts: 19
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: High Beam lights fault

I had something similar with my lights doing loads of weird things and changed the comms unit, making no difference at all. It was eventually found to be the main fusebox in the engine compartment. Some of the relays sandwiched under the main fuses were faulty so I found a fusebox from a Peugeot which looked identical (all the fuses and relays in the same position), and as soon as it was fitted all the problems were gone.Good luck with it all.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

harrybozing is offline Reply With Quote Quote 
Old 09-08-2013   #9
Join Date: Apr 2013
Posts: 18
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: High Beam lights fault

That's worth a try.

There are a number of other electrical problems, which don't impact on the performance of the car, so I haven't made matters more complicated by mentioning them.

One other interesting fact: When the engine is running and the headlights are on, you cannot switch the engine off. You can remove the key, and watch the screens shut down, but the engine keeps going. to switch off the engine, you have to switch off the lights. Providing the headlights are turned off first, the engine stops normally when turning off the ignition.

My mechanic has spent hours on the problem without any luck. So I am hoping this catalogue of problems rings a bell with one of you.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

taxi13 is offline Reply With Quote Quote 
Old 31-08-2013   #10
Join Date: Apr 2013
Posts: 18
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: High Beam lights fault

SORTED

My mechanic pulled in an auto electrician who was sure that the all the problems were being caused by a bad earth. And he was right. He started under the nearside wing and worked out from there. It took a few hours but he eventually came to one earth cable under the headlights which had become detached. It was clear that it had been arcing for some time. When he reconnected it, all my lights worked again. It was amazing how much disruption that bad connection had caused!

It cost me 200, plus the new stalk and coms unit, which were not required. But it could have been far worse.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

taxi13 is offline Reply With Quote Quote 
Old 27-12-2013   #11
Join Date: Nov 2013
Posts: 2
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: High Beam lights fault

As soon as I unlock the doors the lights come on, on high beam (even when not turned on on the stalk). The keep dimming then back onto high beam. Most of the time they are stuck on high. When I lock the doors the lights go off after about 5mins.
Could that be a faulty comm unit or earth?
Any input would be most appreciated before having to pay an auto electrician to try find the root of the problem.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

yorks013 is offline Reply With Quote Quote 
Old 28-12-2013   #12
Join Date: Aug 2004
Posts: 531
Thanks: 14
Trader Rating: 0
United Kingdom 
Re: High Beam lights fault

I would check the fuse box under the bonnet before trying much else, take it out, inspect it and reconnect spraying switch cleaner on the contacts.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

FRANTIC FRAN is offline Reply With Quote Quote 
Old 08-01-2014   #13
Join Date: Apr 2013
Posts: 18
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: High Beam lights fault

When I said "sorted", it was premature.

One of my headlights has stopped working. On checking it, I found that there is only 2.5v at the bulb connector. The other headlight is fine, a full 12v. The earth is also OK. The stalk is working, albeit that somewhere along the way 12v is being stepped down to 2.5 on one headlight.

Going back to previous answers, a change of the fuse box might help. But I want to know if anyone has any other theories, before I waste more money buying parts which make no difference. Are any of the relays connected to the headlights?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

taxi13 is offline Reply With Quote Quote 
Old 08-01-2014   #14
Join Date: Aug 2004
Posts: 531
Thanks: 14
Trader Rating: 0
United Kingdom 
Re: High Beam lights fault

I have one with the engine out, I'll trace the wire back and see where it runs to if it will help you out?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

FRANTIC FRAN is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) high beam problem puntopjc Grande Punto 3 18-03-2013 12:08
(T) High beam not working jneilly699 Stilo 15 23-09-2010 12:37
High Beam goneleft Leisure Lounge 9 21-12-2007 01:50
(T) Head lights high beam.. help Athos Stilo 11 25-03-2007 20:44
(T) High Beam arsedownoz Multipla 1 12-02-2007 14:10