Register Login
endrop - for all your online needs
Reply
 
Thread Tools
Old 01-01-2012   #1
Join Date: Feb 2007
Location: N.Ireland
Posts: 25
Thanks: 1
Trader Rating: 0
United Kingdom 
No signal from Camshaft Sensor P0340 Fault Code

Hi

I recently rebuilt my 2.0 16v HDI engine after timing belt failure but now the car wont start.

See my post on the Eurovan Forum: Ulysse 2.0 16V JTD 2004 Engine repair project

I'm getting the P0340 fault from my PP2000 reader, Screenshots below.

I have replaced the Cam sensor but still get the same fault. screenshots show that there is an RPM reading so I can assume that the Crank sensor is ok and also that last screenshot shows that the Cam & Crank are synchronised.

I disconnected the cam sensor but still get that same fault code although now it is shown as an intermittent fault rather than a permanent one. Also the Cam & Crank do not show as synchronised which is as expected.

Has anyone got any suggestions before I do anything drastic?

I was confident that I set the timing correct. Is it possible for the crank to be 180 deg. out on these engines?

Cheers







__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

MaverickJ is offline Reply With Quote Quote 
Old 01-01-2012   #2
Join Date: Mar 2005
Posts: 1,496
Thanks: 66
Trader Rating: 0
United Kingdom 
Re: No signal from Camshaft Sensor P0340 Fault Code

P0340 Camshaft Position Sensor A Circuit
What does this mean? BD Code P0340 refers to
This indicates that a problem was detected in the camshaft position sensor circuit. Since it says circuit, that means the problem could lie in any part of the circuit - the sensor itself, the wiring, or the PCM. Don't just replace the CPS (camshaft position sensor) and think that will definitely fix it.
Symptoms Possible symptoms of OBD code P0340
Symptoms can include: Hard starting or no start Rough running/misfiring Loss of engine power
Causes Possible causes of OBD code P0340
A code P0340 could mean one or more of the following has happened: a wire or connector in the circuit could be grounded/shorted/broken the camshaft position sensor may have failed the PCM may have failed there exists an open circuit the crankshaft position sensor may have failed
Possible Solutions With a P0340 OBD-II trouble code, diagnosis can be tricky at times. Here are some things to try: Visually inspect all the wiring and connectors in the circuit Check for continuity in the circuit wiring Check the operation (voltage) of the camshaft position sensor Replace the camshaft position sensor as required Check the crankshaft position circuit as well Replace circuit wiring and/or connectors as required Diagnose/replace the PCM as required.
Source: www.permoveo.ltd.uk/

I can only advise that I had this fault flag-up on my Croma 1.9/16v150HP recently but it did not show on a further diagnostic check.

See:
https://www.fiatforum.com/croma/2874...482-p0683.html

120101
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Caravadossi is offline Reply With Quote Quote 
Old 31-01-2012   #3
Join Date: Feb 2007
Location: N.Ireland
Posts: 25
Thanks: 1
Trader Rating: 0
United Kingdom 
Re: No signal from Camshaft Sensor P0340 Fault Code

Finally got round to checking the timing and found that the belt was out by two teeth.

Silly mistake on my part. I had forgot to ensure all round tension on the belt by loosening the three bolts on the cam pulley.

Once set correctly she started up first time.

There doesn't appear to be any damage done as a result but will need to do a proper road test.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

MaverickJ is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Drivers Airbag Light - Fault code P003C Drivers Side Front Impact Sensor 105Dynamic Doblo 6 05-12-2012 16:25
fiat stilo front crash sensor fault code that i cannot clear airbag light on help Brianbb Newbie Central 1 17-08-2011 08:33
(T) Strange signal of O2 sensor hanzs Stilo 1 05-08-2011 19:52
(T) Rotor Posion Sensor Fault Code, Please HELP!!! T-Jet 120 Doblo 9 14-08-2009 20:44