General Old Ulysse Climate Control

Currently reading:
General Old Ulysse Climate Control

zebedee

New member
Joined
Jan 24, 2005
Messages
31
Hello, I have a T plate TDEL with climate control - never found in especially good to be honest, could never tell the difference between auto and eco mode. Recently my air con compressor seized up which caused the fan belt to start smoking - not nice. Anyway, all fixed at the local Pug garage for £530 quid, which included a re-gas of the system.

Yesterday was a good test as it was boiling hot but I still found the air con pretty lame - even with the desired temp set to the minimum, the air being pumped out was cool but not ice cool. With the windows closed, all the blinds closed on the sunroofs, the car was still very warm. Am I expecting too much or should I be phoning the garage up and saying it's still not working?

Cheers,

Dave
 

T14086

Forum Moderator
Joined
Sep 12, 2004
Messages
39,858
Location
Preston
Was the system fully checked for leaks/performance afterwards?

Take it to Fiat next time,better than pug techs:p
 

Alanovich

New member
Joined
Jun 9, 2006
Messages
77
The Aircon on my '95 Ulysse is ice cold, it works an absolute treat. Sounds like there's a problem on yours, I'd get it checked out if I were you.
 

ian001

New member
Joined
Jul 19, 2005
Messages
60
I think the eco mode switches off or cuts back the aircon compressor so keep it on normal.

Kwik Fit do a top up and aircon check with some money back gaurantee if your sytem is not improved afterward may be worth a try
 

ian001

New member
Joined
Jul 19, 2005
Messages
60
one other thought, when my mk 1 Ully had extensive engine work done on it once, the aircon did not work when I got it back. After several attempts the fault was traced to the fact that the battery had been disconnected for so long that the control system had lost its memory and reverted to standard (which does not include aircon) after reprogramming it worked fine.
 
Top