Technical Fiat Brava SX 2000 Key Code Fault

Currently reading:
Technical Fiat Brava SX 2000 Key Code Fault


Jul 12, 2018
Hello everyone, I've got a Fiat Brava SX 1.2 16v, year 2000. A couple of weeks ago I had the heater matrix replaced and a few days ago I noticed that it was still leaking at the pipes that go through the firewall so I left it for that to get fixed aswell.

Today I get called and they tell me that the car won't start. The yellow key code light is on and it turns over but doesn't start. Worryingly the red key doesn't start it as well, code light comes on and stays on the whole time. Tried reseting the battery, moving the steering wheel up/down but nothing helps.

After the initial heater matrix replacement (where the dash had to come out) I drove it for about a week and had no issues with starting, but now it doesn't want to. As they tell me they haven't taken anything out, just replaced the O-rings that connect the pipes that go through the firewall into the engine bay. Since I left it at the shop they told me that the only thing they've done is reparked it and unlocked/locked it a couple of times while they worked on it.

What could be the culprit here? The red key has never had to be used since new. The car sat for 3 years untouched and even then the blue keys worked.
Would love to get your opinions, if anyone else has had this sort of problem.
Hi, I would suspect that the wiring to the immobiliser transponder or similar has been disturbed when the work was done, there is usually a ring or something around the ignition switch that reads the code of the key and sends it to the immobiliser unit, if the code is recognised then the immobiliser will energise some relays at the back of the engine bay and the injection etc. will work. I had something similar when I changed a starter motor and moved those relays out of the way, it weakened a rusty connector under the relay mount and gave an intermittent immobiliser fault. It took me and the AA guy about 45 minutes to understand it.
Hi, thank you for your answer. The issue was fixed, I just forgot to update.
You are absolutely spot on, the immobilizer antenna wire was partially snipped hence the intermittent fault. Had it changed out and it has been working first try ever since.
They really are! Mine just rolled over 130.000km yesterday so it's got a fair amount of driving left in it :)