Register Login
im Axle Specialists
Reply
 
Thread Tools Search this Thread
Old 24-04-2018   #1
Join Date: Apr 2018
Posts: 2
Thanks: 0
Trader Rating: 0
Germany 
Exclamation Please help! Tried everything! ASR, ecu fault, loose connection Stilo 2003 16v 1.6

I'm at my wit's end so welcome all serious suggestions.

For the past 4 months I've been getting the dreaded ASR, Alternator, loose connection fault in my 2003 Stilo 16v 1.6.

So far I have:

-Replaced the ECU with a new one
-Checked all Earths
-Checked battery voltage and alternator charge
-Cleaned MAP sensor
-Cleaned all battery contacts
-Cleaned entire fuse box
-Checked wiring harness connection to ECU

And since that did not fix the problem:

-Died a little inside

I'm really hoping that you guys can offer some sage advice on what could be the problem. I've read so many forums on this d*mn problem and no one seems to have a solution. The strange thing is, sometimes it does the asr, loose connection fault, while other times the engine just cuts out dramatically with the engine light on. Two different symptoms of the same problem?

Thanks for the help!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

SoDunn is offline Reply With Quote Quote 
Old 25-04-2018   #2
Join Date: Dec 2003
Location: The land that time forgot
Posts: 3,244
Thanks: 249
Trader Rating: 0
United Kingdom 
Re: Please help! Tried everything! ASR, ecu fault, loose connection Stilo 2003 16v 1.

If the battery is holding charge then it's possibly a bad earth. There's a couple of earth points in the engine bay.. one on each wing (at least on mine - a 1.9JTD).

Locate each earth point, detach the earth cable from the body, clean up the contact area (use degreaser first and then wire wool etc. on both the cable and the body) then refit it. Once it's tightened up put some grease around it to stop it corroding (Vaseline is best, since it conducts electricity.. otherwise any grease better than no grease).

That should do it.

Check the battery voltage too. It should be 12.6 volts with the engine not running.. and about 14.5 at a fast idle. 11.x volts or less (engine off) is a duff battery.


Ralf S.
__________________
No bullets for chaingun
Ralf S. is offline Reply With Quote Quote 
Old 25-04-2018   #3
Join Date: Aug 2011
Location: Edinburgh
Posts: 275
Thanks: 16
Trader Rating: 0
bri1232 has donated!
United Kingdom 
Re: Please help! Tried everything! ASR, ecu fault, loose connection Stilo 2003 16v 1.

it could be your Ecu is faulty does your engine cut out.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

bri1232 is offline Reply With Quote Quote 
Old 26-04-2018   #4
Join Date: Apr 2018
Posts: 2
Thanks: 0
Trader Rating: 0
Germany 
Re: Please help! Tried everything! ASR, ecu fault, loose connection Stilo 2003 16v 1.

Ok, went in with a code reader today and it came up with a bunch for the throttle position sensor (low voltage, incorrect position etc.) as well as a number of other circuitry errors.

I've replaced the ECU with a new, virginised one so it's not that, and my battery readouts are healthy, but could it possibly be a battery problem?

Or could Earth corrosion cause voltage problems in the circuits?

The engine Earths are damn hard to get to so I'm considering that a last resort!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

SoDunn is offline Reply With Quote Quote 
Old 26-04-2018   #5
Moderator
 
Davren's Avatar
Join Date: Jul 2008
Location: London, UK.
Posts: 13,942
Thanks: 1487
Trader Rating: 5
Davren has donated!
United Kingdom 
Re: Please help! Tried everything! ASR, ecu fault, loose connection Stilo 2003 16v 1.

Which fault codes did you get?
.
__________________
Stilo Parts For Sale: Connect Nav+ Map Discs - Wiper Motor (NEW) - JTD/JTDM Front Brake Discs (NEW) - 5 of 215/45-17 Alloy Wheels

For details, click here: http://www.fiatforum.com/classifieds...0&ppuser=48514
Davren is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) Stilo 1.9 115bhp - Loose Connection EBD ABS ASR and power steering faulty Xavstack Stilo 5 18-04-2018 23:06
(T) fiat stilo 1.6 hatchback 2002 mod, ASR, loose connection stistus Stilo 11 06-03-2015 01:29
(T) ASR Failure Loose Connection [ECU defective?] Simonch6 Stilo 152 14-02-2015 10:33
(T) ASR Loose connection error- How can I tell if the ECu if fried? joekupa Stilo 22 18-06-2012 22:08