Register Login
Shop4Parts - UK's largest online superstore for FIAT and Alfa Romeo parts
Reply
 
Thread Tools
Old 20-01-2011   #1
Join Date: Jan 2011
Posts: 14
Thanks: 0
Trader Rating: 0
Ireland 
Stilo engine fault?

Hi

I have an 02 1.2 Stilo and i was driving only about 10 minutes today and the engine warning light started flashing and 'engine fault' appeared on display, The car started chugging, even when its ticking over it starts making a 'deh deh deh deh deh' kind of noise, the exhaust is chugging too.

I got it towed back to my friends house because i'm an hour from home and the 2 garages i trust. I'm going to hopefully have someone come and look at it tomorrow but in the mean time can anyone advise on what it could be? i've been messed around by garages in the past. Any help greatly appreciated

Thanks

Chantelle
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by ch1984; 20-01-2011 at 17:05. Reason: forgot to put a detail in
ch1984 is offline Reply With Quote Quote 
Old 20-01-2011   #2
Whaddya mean too old?
 
Deckchair5's Avatar
Join Date: May 2005
Location: Roman city Bath
Posts: 5,589
Thanks: 718
Trader Rating: 0
Deckchair5 has donated!
United Kingdom 
Re: Stilo engine fault?

Sounds like an ignition coil has gone. Very common. Fault code if you can read it will tell you which cylinder it is
Click image for larger version

Name:	coil low voltage connector.JPG
Views:	151
Size:	16.0 KB
ID:	85820
or you can pull off each coil electrical connector and look for the one that makes no difference to idle speed.

About 40 new and 10mins to fit. Very easy to replace it yourself, just one bolt to remove
Name:  coil new.JPG
Views: 5117
Size:  4.7 KB
Shop4parts.co.uk sell them
__________________
02 Stilo 1.6 Dynamic 3 door
99 Bravo 1.2SX

Last edited by Deckchair5; 20-01-2011 at 18:33.
Deckchair5 is offline Reply With Quote Quote 
Old 20-01-2011   #3
Join Date: Jan 2011
Posts: 14
Thanks: 0
Trader Rating: 0
Ireland 
Re: Stilo engine fault?

[QUOTE=Deckchair5;2676386]Sounds like an ignition coil has gone.

Thanks, i spoke to someone earlier and they mentioned that too.. fingers crossed thats all it is..

Appreciate your help

Chantelle
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

ch1984 is offline Reply With Quote Quote 
Old 20-01-2011   #4
Join Date: Aug 2010
Location: Gravesend,Kent
Posts: 20
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Stilo engine fault?

hi ...had same problem and was only the coil ...excellent "how to " in guide section...good luck...do it yourself as garage charged me 130.00...will do myself next time!!!! good luck m8
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Gordon1610 is offline Reply With Quote Quote 
Old 20-01-2011   #5
Join Date: Jan 2011
Posts: 14
Thanks: 0
Trader Rating: 0
Ireland 
Re: Stilo engine fault?

Quote Originally Posted by Gordon1610 View Post
hi ...had same problem and was only the coil ...excellent "how to " in guide section...good luck...do it yourself as garage charged me 130.00...will do myself next time!!!! good luck m8
Hi thanks,

I'm feeling a little more relieved now since so many people have mentioned the coil. I dont really know anything about cars unless a problem has come up but i never had an issue with a coil. What will i need to change it, barr a new coil itself?

Thanks

Chantelle
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

ch1984 is offline Reply With Quote Quote 
Old 21-01-2011   #6
Join Date: Jan 2011
Posts: 14
Thanks: 0
Trader Rating: 0
Ireland 
Re: Stilo engine fault?

Hi guys

Found out today it was the 4th coil that was misfiring so thankfully thats getting sorted now

Appreciate all the help and advice

Chantelle
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

ch1984 is offline Reply With Quote Quote 
Old 21-01-2011   #7
Join Date: Jan 2011
Posts: 113
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Stilo engine fault?

it will take you 2 minutes. unscrew the nut unclip the yellow socket pull the coil off slide new coil on. put a bit of WD40 or something like it on the bottom to help slide it on then re clip yellow socket and tighten screw back on. good luck
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

jqx81o is offline Reply With Quote Quote 
Old 22-01-2011   #8
Join Date: Jan 2011
Posts: 14
Thanks: 0
Trader Rating: 0
Ireland 
Re: Stilo engine fault?

Quote Originally Posted by jqx81o View Post
it will take you 2 minutes. unscrew the nut unclip the yellow socket pull the coil off slide new coil on. put a bit of WD40 or something like it on the bottom to help slide it on then re clip yellow socket and tighten screw back on. good luck
Hey

i actually got fast fit to put it in, i bought the part for 45 and they put it in no charge but i threw him 10.. so it worked out well thankfully

thanks for your help though, i know what to do for next time if it happens again anyway

Chantelle
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

ch1984 is offline Reply With Quote Quote 
Old 19-05-2014   #9
Join Date: May 2014
Posts: 1
Thanks: 0
Trader Rating: 0
Macedonia 
Re: Stilo engine fault?

Hello everyone,

i see that some of u are having the same problem as me, but u all fixed it "easily" because you have gasoline engines. I have 2001 Fiat Stilo 1.9 JTD and it doesnt have coils. How to fix my problem ?

p.s. the problem is similar like yours. during i drive it starts to bip the light and a text "Engine Fault" shows up on the screen. it happens when i wait on traffic light, when i drive, or when i start engine.

Regards
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

krapec is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) Engine fault - Stilo catglover Stilo 5 30-04-2008 11:14
(T) Stilo Engine Fault sazzy81 Stilo 5 12-03-2008 12:24
(T) Stilo 1.2 Engine Fault koe_182 Stilo 7 04-06-2007 18:19
(T) Stilo Engine Fault Puppy Stilo 0 13-06-2006 10:39