Register Login
Save up to 15% with Adrian Flux insurance!
Reply
 
Thread Tools
Old 16-11-2008   #1
Join Date: Nov 2008
Location: cumbria
Posts: 36
Thanks: 0
Trader Rating: 0
United Kingdom 
Unhappy 1.6 no throttle, limp mode [ECU?]

hi guys new member needing help, pulled away briskly from a t junction, about to change to 2nd then engine management comes on an no throttle, idle goes up to 1250 rpm, will rise up to 1300rpm with throttle, but NO power at all, fault is coming on as soon as i start the engine,
any ideas what i am looking at billwise, nearest agents in windermere, an seam quick to change most expensive parts first!!!!!!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

fennbeam is offline Reply With Quote Quote 
Old 16-11-2008   #2
Join Date: Nov 2008
Location: cumbria
Posts: 36
Thanks: 0
Trader Rating: 0
United Kingdom 
re: 1.6 no throttle, limp mode [ECU?]

also tried to start it cold just now an engine takes, but dies instantly, please help, am losing patience now, box of matches an can of 98 at the ready, its my only form of transport out in the sticks
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

fennbeam is offline Reply With Quote Quote 
Old 16-11-2008   #3
Join Date: May 2006
Posts: 886
Thanks: 105
Trader Rating: 0
yellowstilo has donated!
Netherlands 
re: 1.6 no throttle, limp mode [ECU?]

reading the stored fault codes will point you in the right direction - could be throttle body, engine ecu and many other things....
If you post the fault codes here you will get plenty of useful replies...
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

yellowstilo is offline Reply With Quote Quote 
Old 16-11-2008   #4
Forum Moderator
 
T14086's Avatar
Join Date: Sep 2004
Location: Preston
Posts: 29,985
Thanks: 1063
Trader Rating: 0
T14086 has donated!
United Kingdom 
re: 1.6 no throttle, limp mode [ECU?]

Is your battery ok? sounds as if you need a throttle learn carried out.

Try the following;

1) switch ignition on (DONT START) for one minute
2) switch ignition off one minute
3) start car (DONT TOUCH THROTTLE AT ALL) and let idle until cooling fan cuts in (10-15mins)
4) switch off
5) repeat step 1
6) repeat step 2

If this dont work your looking at ECU,throttle body or wiring in between these 2 components at fault.
Thanks fennbeam thanked for this post
__________________
http://www.chryslerforum.co.uk//

Last edited by T14086; 16-11-2008 at 16:40.
T14086 is offline Reply With Quote Quote 
Old 17-11-2008   #5
Join Date: Nov 2008
Location: cumbria
Posts: 36
Thanks: 0
Trader Rating: 0
United Kingdom 
re: 1.6 no throttle, limp mode [ECU?]

battery is fine, but when car was still warm it started an idled at 2500rpm, now its cold all it does is briefly takes then dies, like choke/ enrichment is not operating, car has not given me any real probs. like this before, am trying to get it recovered to a garage to read fault codes an shed some light on the subject, even a diesil mech. (merc.) like myself is stuffed without a diagnostic tool, i don,t think its acc. pedal learning at the moment but i could be wrong, thanks anyway both of you so far for your responce, i will keep you posted
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

fennbeam is offline Reply With Quote Quote 
Old 20-11-2008   #6
Join Date: Nov 2008
Location: cumbria
Posts: 36
Thanks: 0
Trader Rating: 0
United Kingdom 
re: 1.6 no throttle, limp mode [ECU?]

hi again guys, eventually got some fault codes from the garage, p1220 an p1687, looks like a prob. fault with the acc. pedal ? garage has tried a new pedal ass. on but no luck, I have sent them the learn process kindly supplied by T14086 thinking that even a new pedal needs learning ?? am I correct assuming this, any light you guys can shed on this will help me an the garage get the stilo back to its best point, driving !!!!!!!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

fennbeam is offline Reply With Quote Quote 
Old 20-11-2008   #7
Forum Moderator
 
T14086's Avatar
Join Date: Sep 2004
Location: Preston
Posts: 29,985
Thanks: 1063
Trader Rating: 0
T14086 has donated!
United Kingdom 
re: 1.6 no throttle, limp mode [ECU?]

Acc pedal does not need learning, its just 2 potentiometers.

Is it a Fiat garage you are going too?
Thanks fennbeam thanked for this post
Likes Fiatallday liked this post
__________________
http://www.chryslerforum.co.uk//
T14086 is offline Reply With Quote Quote 
Old 20-11-2008   #8
Join Date: Nov 2008
Location: cumbria
Posts: 36
Thanks: 0
Trader Rating: 0
United Kingdom 
re: 1.6 no throttle, limp mode [ECU?]

no its a private / normal but honest bunch that my dad uses, has done a good few stilo,s an on good terms with nearest fiat agents, not too sure how much info passes with parts sold to them yet though ?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

fennbeam is offline Reply With Quote Quote 
Old 21-11-2008   #9
Whaddya mean too old?
 
Deckchair5's Avatar
Join Date: May 2005
Location: Roman city Bath
Posts: 5,589
Thanks: 718
Trader Rating: 0
Deckchair5 has donated!
United Kingdom 
re: 1.6 no throttle, limp mode [ECU?]

Hmmm, you garage is going about it from the wrong end. P1687 is the throttle valve in the engine not the accelerator pedal. Do a search here on P1687 and you'll find a lot of info about it.
Click image for larger version

Name:	DSC00221.JPG
Views:	109
Size:	120.0 KB
ID:	53545
First thing I'd do is disconnect the throttle valve electrical connector, inspect the pins for poor contact, spray with contact cleaner to clean up oxidation and reconnect.

I'd also do a throttle body valve clean whilst i was there as in the Stilo Guides

If that works then it'll need a throttle relearn procedure, again do a search here for how to do that

Your codes are saying it's lost contact with the throttle body valve and is totally lost so it's not going to give you any throttle because it doesn't know where it is in the first place
Thanks fennbeam thanked for this post
__________________
02 Stilo 1.6 Dynamic 3 door
99 Bravo 1.2SX

Last edited by Deckchair5; 21-11-2008 at 09:21.
Deckchair5 is offline Reply With Quote Quote 
Old 21-11-2008   #10
Join Date: Nov 2008
Location: cumbria
Posts: 36
Thanks: 0
Trader Rating: 0
United Kingdom 
re: 1.6 no throttle, limp mode [ECU?]

now that makes sense, thanks for the info deckchair5, I have passed info on to the garage guys, now to see if can get it sorted by monday, heres hoping
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

fennbeam is offline Reply With Quote Quote 
Old 24-11-2008   #11
Join Date: Nov 2008
Location: cumbria
Posts: 36
Thanks: 0
Trader Rating: 0
United Kingdom 
re: 1.6 no throttle, limp mode [ECU?]

well it had to happen, I got a call early at work by the garage to say he was giving up an towing it down to the fiat agents in winderemere an could I phone them to expect it, he would not charge me so far except for the acc. pedal unit he fitted, I told him to refit my old one cause its nothing to do with the fault an return it as unused, I had warned him he is looking in the wrong place as soon as I knew from info on this brill. forum,
so now I am at the mercy of the local agents, hope they don,t just jump for an ecu then work backwards like history predicts !!!!!!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

fennbeam is offline Reply With Quote Quote 
Old 27-11-2008   #12
Join Date: Nov 2008
Location: cumbria
Posts: 36
Thanks: 0
Trader Rating: 0
United Kingdom 
Unhappy re: 1.6 no throttle, limp mode [ECU?]

got the dreaded call today from the fiat agents, they could not "talk" to the ecu so could they go ahead an order a new one at 200 an something pounds, then work from there on the diognostics, I just knew they would go for the ecu first ! an still poss. more parts needed, I am on my knee,s praying now, 1st garage still would like me to pay for the acc. pedal ass. that I did not need, which took 3 hours to fit ?? not forgetting the 90 to get the car to them, this is beyond expensive now, what do you guys think, any thoughts would be helpfull guys
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

fennbeam is offline Reply With Quote Quote 
Old 27-11-2008   #13
Forum Moderator
 
T14086's Avatar
Join Date: Sep 2004
Location: Preston
Posts: 29,985
Thanks: 1063
Trader Rating: 0
T14086 has donated!
United Kingdom 
re: 1.6 no throttle, limp mode [ECU?]

what garage in windermere?

I wouldn't pay 1st garage for getting it wrong (was it a fiat garage?) just diag time, tell them to put old part back on then
__________________
http://www.chryslerforum.co.uk//
T14086 is offline Reply With Quote Quote 
Old 27-11-2008   #14
Join Date: Nov 2008
Location: cumbria
Posts: 36
Thanks: 0
Trader Rating: 0
United Kingdom 
re: 1.6 no throttle, limp mode [ECU?]

1st garage was a general private garage, told to put old pedal back/ don,t see why I should pay etc. they said fiat won,t take it as a return/ not used, !!! I work for merc. an a good parts customer can return parts no prob. fiat agent in windermere is rayrigg motors, whats your thoughts on diagnosis so far T14086
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

fennbeam is offline Reply With Quote Quote 
Old 28-11-2008   #15
Forum Moderator
 
T14086's Avatar
Join Date: Sep 2004
Location: Preston
Posts: 29,985
Thanks: 1063
Trader Rating: 0
T14086 has donated!
United Kingdom 
re: 1.6 no throttle, limp mode [ECU?]

fiat parts wont take it back (electrical component) however its going to be a long battle to get a refund from local garage, might just have to put that one down to experience. Rayrigg will see you alright
Thanks fennbeam thanked for this post
__________________
http://www.chryslerforum.co.uk//
T14086 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) Stilo in Limp Mode pachamama Stilo 10 29-11-2011 15:43
(T) Limp home mode gtturbs Punto (Mk2/2b) 1 11-11-2008 19:11
(G) Auto gearbox getting into limp mode? Ulysse16V Ulysse 0 06-03-2007 05:31
(G) 2.0 hdi problems - limp mode??? fiatone Scudo 1 01-03-2007 20:34
(G) MP3 Player - Shuffle (MIX) mode, Repeat mode etc. Honzus Grande Punto 29 26-06-2006 19:22