Register Login
FIAT Auto Specialist Team
Reply
 
Thread Tools Search this Thread
Old 11-05-2011   #1
Join Date: Jul 2009
Location: rugby
Posts: 5
Thanks: 0
Trader Rating: 0
United Kingdom 
1999 non turbo scudo lack of/loss of power

i have looked thru loads of pages trying to find the answer but not found anything.
start van up, and it can and will drive not too bad, but then it will lose power and only move with accelerator pedal all the way to the floor.
sometimes i start it up, and it will not rev. turn off, and restart and it will then run fine again.
yesterday drove from coventry to rugby with out issues untill i got to my destination, and lost power. started up 2 mins later and was fine but only for a very short journey of maybe 500yards.lost power again. turned off then restarted, and drove 8 miles home without issues.

the problem is happening most times when i drive it..
any one had this problem, which is now sorted????
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

daz7505 is offline Reply With Quote Quote 
Old 11-05-2011   #2
Telford's Own...
 
Ffoxy's Avatar
Join Date: Apr 2007
Posts: 9,824
Thanks: 373
Trader Rating: 0
Ffoxy has donated!
United Kingdom 
Re: 1999 non turbo scudo lack of/loss of power

Start with the basics, if it has been kept regularly & properly serviced this will not apply.

Replace the air filter & fuel filter, drain the water trap & see how that affects it. Once you can rule out the simple & the obvious you wont waste time & money investigating the more difficult things unless you have to.
__________________
Ex Suzuki SV1000S jockey, now a former 1.9 MJet Grande Punto Sporting pilot curently driving a Hyundai i30 1.6 Premium.
Ffoxy is offline Reply With Quote Quote 
Old 13-05-2011   #3
Join Date: Feb 2011
Posts: 42
Thanks: 5
Trader Rating: 0
United Kingdom 
Re: 1999 non turbo scudo lack of/loss of power

What pump is it lucas or bosch ?
had same problem on my dispatch turned out to be a problem
with the fuel tank a large lump of oily mass was moving around
and blocking the pickup now and again
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Motorbikeman is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
fiat coupe 20v turbo 1999 loss of power after 3.5 revs HELP PLEASE FOXY1 Lets Talk FIAT 1 05-05-2010 20:27
(G) loss of power marena 55 1999 dean666 Marea 2 15-04-2008 11:57
(T) Major power loss and lack of revving SycoSeicento Cinquecento / Seicento 6 30-12-2007 15:29
(T) punto 1999 loss of power DEREKS FIAT Punto (Mk2/2b) 1 04-10-2006 20:43