Register Login
Save up to 15% with Adrian Flux insurance!
Comment
 
Guide Tools Search this Guide
<!-- google_ad_section_start -->Why Doesn't my new aftermarket stereo doesn't work<!-- google_ad_section_end -->
Why Doesn't my new aftermarket stereo doesn't work
Published by Ziggy122
12-01-2015
Difficulty Level: 2

User Rated:Unrated

Show Printable Version  Email this Page 
Disclaimer

So here it is
This is your own work, I personally nor are Fiat Forum Reliable for any damages or injuries to you / your surroundings / your equipment / items

This is simply a guide on whats what
No equipment list - as this will vary greatly on your available items
A multimeter wouldn't hurt, wire and connection terminals MAY be required as well

Thanks Bobtoo, Tov, Mean Machinist, deagz thanked for this post
Likes iori1210, nitramtpr, kido resuri, Bobtoo, Tov and 1 others liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Contents
Old 03-03-2015   #1
Join Date: Jan 2015
Posts: 111
Thanks: 7
Trader Rating: 0
United Kingdom 
Re: Why Doesn't my new aftermarket stereo doesn't work

Thanks, will try this at the weekend!

Couldn't get my aftermarket HU working last time so I gave up
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

deagz is offline Reply With Quote Quote 
Old 09-10-2015   #2
Join Date: Oct 2015
Posts: 3
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Why Doesn't my new aftermarket stereo doesn't work

Hi,
Do I need to put 2 fuses in piggyback holder? original cigar lighter 20amp and 2 amp? if so where does the 2 amp go? lower or higher slot?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

mo1965 is offline Reply With Quote Quote 
Old 25-10-2015   #3
Join Date: Oct 2015
Posts: 1
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Why Doesn't my new aftermarket stereo doesn't work

Hi 20 amp goes in lower one then 2amp in top,if its the same as the one I have just done works a treat, best to put lower one in first and then check if cigar lighter works. Hope this helps.
Likes BlueNeedles liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

ewg is offline Reply With Quote Quote 
Old 10-02-2016   #4
Join Date: Feb 2016
Posts: 4
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Why Doesn't my new aftermarket stereo doesn't work

Superb write-up; thanks very much for putting this together.

Going to fit my new Sony Head Unit on Friday and was scratching my head about switched-lives and CAN BUS until I read this.

Not sure if it helps, but I found a pin-out diagram on my factory-fitted CD unit which is really clear in showing where the connectors go - thought I'd attach in case it's of use to someone.
Attached Thumbnails
Click image for larger version

Name:	2016-02-10 13.13.49.jpg
Views:	103
Size:	557.4 KB
ID:	164518  
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Tov is offline Reply With Quote Quote 
Old 20-03-2016   #5
Join Date: Mar 2016
Posts: 32
Thanks: 2
Trader Rating: 0
United Kingdom 
Re: Why Doesn't my new aftermarket stereo doesn't work

Thanks for posting this guide. The Punto I've just bought has permanent 12V only on its aftermarket stereo, so I'll be sorting that out soon.

One question- is there a way to connect to the illumination or am I as well to give that the ignition switched 12V feed too?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Bobtoo is offline Reply With Quote Quote 
Old 10-04-2017   #6
Join Date: Aug 2013
Posts: 452
Thanks: 33
Trader Rating: 0
nitramtpr has donated!
United Kingdom 
Re: Why Doesn't my new aftermarket stereo doesn't work

Great guide Ziggy, I used this to get my Pioneer stereo working. It was a bit easier on that one, the Pioneer comes with swappable red and yellow wires. I left the yellow connected to yellow, and just connected the red out of the Pioneer into the cigar lighter connection exactly as you did. Worked a treat.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

nitramtpr is offline Reply With Quote Quote 
Old 19-11-2017   #7
Join Date: Sep 2017
Posts: 33
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Why Doesn't my new aftermarket stereo doesn't work

help I have a pioneer stereo, need to connect it properly to stop battery drainage, what do I need to buy to sort it. I have the iso adapter as came with stereo
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Charley1985 is offline Reply With Quote Quote 
Old 01-12-2017   #8
Join Date: Aug 2013
Posts: 452
Thanks: 33
Trader Rating: 0
nitramtpr has donated!
United Kingdom 
Re: Why Doesn't my new aftermarket stereo doesn't work

All you need to do is piggyback off the power lead that goes to the cigarette lighter. It is fairly straightforward, you'll just need a short length of wire to go up to the radio and then connect into the cigarette power wire. If you don't have any crimping tools you can cut the power wire and then use a chocolate strip to connect it back up.

https://www.ebay.co.uk/itm/Chocolate...n/292032902019

You'll need one of those little connectors for both the cigarette socket and and then one for the Pioneer end.
Thanks Charley1985 thanked for this post
Likes Charley1985 liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

nitramtpr is offline Reply With Quote Quote 
Old 01-12-2017   #9
Join Date: Sep 2017
Posts: 33
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Why Doesn't my new aftermarket stereo doesn't work

thanks I've done it but 3 days later my battery is flat 🤔
It's not on road yet as not taken my test but i run it weekly to keep it ticking over, I hope its just the weather & non running of car everyday that's caused the battery issue & not the sterio.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Charley1985 is offline Reply With Quote Quote 
Comment
Currently Active Users Viewing This Guide: 1 (0 members and 1 guests)
 
Guide Tools Search this Guide
Search this Guide:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Guide Guide Starter Category Comments Last Post
(T) New car stereo doesn't work Czarnik Punto (Mk2/2b) 2 23-02-2014 14:45
(T) A/C doesn't work gonz81bs Bravo / Brava 15 01-08-2012 18:23
Why doesn't It Work??? chaazureblue Blue and Me 2 14-12-2010 15:17
MP3 Doesn't Work on FIAT Grande Punto 2008 5 door (08 Reg) Blaupunkt Stereo FastFurious65 I.C.E 7 14-03-2009 19:46
(G) Old car stereo doesn't work Laurielou Punto (Mk2/2b) 1 23-01-2009 17:24