Register Login
im Axle Specialists
Reply
 
Thread Tools
Old 07-09-2006   #1
Join Date: Sep 2006
Posts: 3
Thanks: 0
Trader Rating: 0
United Kingdom 
Radio not working, Weekend 2.0l 20v

Hi.....can anybody help ?
I left my sunroof on tilt and you guessed it , we had a downpour. The radio and dash were completely soaked, and although the radio initially worked, the next day it would'nt switch on. At this time the clock was still working.
I removed and tested the 10a fuse in the main box (no13) and it was OK. I was a little confused because this fuse is meant to be the main supply to the clock and radio, but the clock remained on. I then removed and checked fuse no12 which is the power supply to the instrument panel, the clock went off when I removed this fuse, but did not come back on when I put it back. I have also pulled the radio out and checked the 10a fuse at the rear, but that was also OK. Now neither my radio or my clock are working, can anyone help ?
Thanks Mark
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

iggypups is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) How many Marea's / Weekends polecat Marea 195 10-04-2016 21:56
(T) Marea Weekend Radio stays on and auto revving vaughan Marea 0 24-08-2006 00:28
Die Hard!!! The Negotiator Leisure Lounge 27 24-04-2006 23:20