Register Login
Mr FIAT - Your #1 source for vintage car parts
Reply
 
Thread Tools
Old 29-01-2015   #1
Join Date: Apr 2006
Location: Belfast
Posts: 147
Thanks: 1
Trader Rating: 0
United Kingdom 
Urgent help needed! Windscreen demister not working!

Hi guys,

Hope y'all can help me here. Recently my Windscreen Demister has become ineffective to the point where it is now dangerous. I'm having to frantically wipe the windscreen so I can see where I'm going. The windows steam up in the sort of conditions you would normally expect.

The fan comes on no problem but I don't feel much air coming out of the winscreen vents. It does manage to clear a very small part at the bottom of the windscreen but this isn't much use.

Can someone give me advice on the correct diagnostics to take for this? What to check first etc and if anyone else has similar problems?

I have searched the forums and getting a mish mash of results but not come accross any with the exact same problems that I'm having (apologies if I missed anything relevant)

Thank you!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

VinylHogger is offline Reply With Quote Quote 
Old 29-01-2015   #2
Loving my T-Jet Sport
 
deebo007's Avatar
Join Date: Feb 2014
Location: Lichfield
Posts: 62
Thanks: 4
Trader Rating: 0
deebo007 has donated!
United Kingdom 
Re: Urgent help needed! Windscreen demister not working!

First thing to do is change your pollen filter. I had this issue a month ago, changing the filter has helped a huge amount. It's next to the clutch pedal in the drivers foot-well, not easy to get too. Pretty sure mine was the original one from 2009 when built.
__________________
MY59 Bravo Sport, 1.4 T-Jet (150), 18" Alloys, Climate, Xenons, Skydome, Arm Rest, Maserati Blue. Love it!
deebo007 is offline Reply With Quote Quote 
Old 29-01-2015   #3
Join Date: Sep 2009
Location: Bucharest
Posts: 2,049
Thanks: 140
Trader Rating: 0
Romania 
Re: Urgent help needed! Windscreen demister not working!

The Bravo forum is full of similar problems with the climate control. ( you do have automated 2 zone climate control)
Basically the problem is: the flaps that direct air to the windscreen are not working; They are not working because there is a small connector piece between the servo motor and the flaps; that small plastic piece breaks... so now the servo motor spins freely but the flaps do not move.

This fault can cause different symptoms among witch: air not moving to the correct vents, scree demister not working, ; air not blowing hard enough even tho you can hear the blower working hard...etc.
The servo an the broken piece:Click image for larger version

Name:	P04-03-10_16-15.jpg
Views:	155
Size:	99.6 KB
ID:	149061
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by aurick86; 29-01-2015 at 16:00.
aurick86 is offline Reply With Quote Quote 
Old 29-01-2015   #4
Join Date: Dec 2013
Location: lancashire
Posts: 52
Thanks: 1
Trader Rating: 0
United Kingdom 
Re: Urgent help needed! Windscreen demister not working!

In the mean time i suggest you put shaving foam or washing up liquid on the windscreen to help reduce steam on the windscreen, works like a charm
__________________
T-JET 150 Sport
ozzy1993 is offline Reply With Quote Quote 
Old 29-01-2015   #5
Join Date: Aug 2014
Posts: 417
Thanks: 25
Trader Rating: 0
United Kingdom 
Re: Urgent help needed! Windscreen demister not working!

I had the same issue with my bravo, in the end i brought a re-useable dehumidifier which I first placed near the screen i still had the same problem, so I decide the move the dehumidifier near the hand brake , and opened all my windows in my car and drove for around 10mins to allow any wet areas in my car dry up.

After I shut all the windows and put the heating system on full level 4 setting for around 30mins, and carry on using the dehumidifier the problem has gone I don't get streamed up windows.

This is the one I have: Once the spot on the dehumidifier turns dark blue place in the microwave and heat up for 5mins I think and re use.



I brought this from Asda.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

BravoCity is offline Reply With Quote Quote 
Old 30-01-2015   #6
Join Date: Apr 2006
Location: Belfast
Posts: 147
Thanks: 1
Trader Rating: 0
United Kingdom 
Re: Urgent help needed! Windscreen demister not working!

Thanks for the suggestions so far guys! I do in deed have dual climate control fitted (sorry for not pointing that out).

So what would the correct order be in diagnosing this?

Replace pollen filter?

Check if flap piece is broken (is there a rough guide on how to do this?)

Dehumidify?

I'll bear in mind the washing up liquid solution in the meantime (rather that than shaving foam).

I just want to fix this in the quickest way possible whatever way that may be.

Thanks again!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by VinylHogger; 30-01-2015 at 00:04.
VinylHogger is offline Reply With Quote Quote 
Old 30-01-2015   #7
Yeahhhhhhh!
 
tomtom2011's Avatar
Join Date: Aug 2011
Location: Manchester City Centre
Posts: 94
Thanks: 2
Trader Rating: 0
tomtom2011 has donated!
United Kingdom 
Re: Urgent help needed! Windscreen demister not working!

I had the same issue. Was the motor and dashboard out job. Or if you are not bothered about auto recirculation then take the wipers off, take off the guard and prop the flap open
__________________
Fiat Stilo Active 1.4 16V - Sold
Fiat Bravo 1.6 Turbo Eco Dynamic (Grey) !!
tomtom2011 is offline Reply With Quote Quote 
Old 30-01-2015   #8
Join Date: Jun 2008
Posts: 2,458
Thanks: 101
Trader Rating: 0
Morocco 
Re: Urgent help needed! Windscreen demister not working!

Quote Originally Posted by VinylHogger View Post
Thanks for the suggestions so far guys! I do in deed have dual climate control fitted (sorry for not pointing that out).

So what would the correct order be in diagnosing this?

Replace pollen filter?

Check if flap piece is broken (is there a rough guide on how to do this?)

Dehumidify?

I'll bear in mind the washing up liquid solution in the meantime (rather that than shaving foam).

I just want to fix this in the quickest way possible whatever way that may be.

Thanks again!
Your problem has already been diagnosed here. if you were going to replace the part yourself, the next step is get the elearn software so that you can have the disassembly procedure for that actuator.

The broken motor will not register an error code since it's just the plastic tip that's certainly broken.

I also have a broken A/C actuator in my car and I found easily by checking under the dash, I could move the plastic bits manually but I don't think you're as lucky, the one broken in your car is probably very deep inside the dash.
__________________

Last edited by Tad-bravo; 30-01-2015 at 11:09.
Tad-bravo is offline Reply With Quote Quote 
Old 30-01-2015   #9
Join Date: Sep 2009
Location: Bucharest
Posts: 2,049
Thanks: 140
Trader Rating: 0
Romania 
Re: Urgent help needed! Windscreen demister not working!

If the problem is indeed the plastic bit for the motor controlling the air direction (you can easily check by directing air to the different vents only windscreen, only front, only feet )
then the quick and easy solution is to remove the radio HU and through there you can access the flaps and move them so air is directed to the windscreen; then use some wire or tape to keep the wheels in the right place. put back the HU and you will be fine until you decide to replace the bits.

If the problem is the recirculation flap ( but less probabbly because it uses a different system.. does not use the same connector bits) then remove wipers and the plastic cover and improvise something to keep the flap open.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

aurick86 is offline Reply With Quote Quote 
Old 30-01-2015   #10
Join Date: Feb 2008
Location: Middlesbrough
Posts: 588
Thanks: 21
Trader Rating: 0
United Kingdom 
Re: Urgent help needed! Windscreen demister not working!

Yes its been said but I Would check the air recirc flap first.

Mine had exactly this issue, exacerbated in the cold weather when the compressor is not active.

Its a 10 minute job to check (and "fix").
Remove the wipers, then remove the scuttle panel (the black plastic grill under the windscreen). Careful how you remove as there are plastic bits that can snap off if you are not careful.
Once removed you will see an intake around the centre, underneath the windscreen. Turn the ignition on and get someone to press the recirc button on and off. If this doesnt do anything then it is goosed. To fix I simply opened the flap and tied it open with some gardening wire. The problem went instantly. And I mean literally 50m down the road it cleared and I never had an issue again. Admittedly going in tunnels you cant shut the thing but I didnt notice in the next 2 or 3 years I had the car
Likes urobee liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

PROV is offline Reply With Quote Quote 
Old 31-01-2015   #11
Join Date: Apr 2006
Location: Belfast
Posts: 147
Thanks: 1
Trader Rating: 0
United Kingdom 
Quote Originally Posted by PROV View Post
Yes its been said but I Would check the air recirc flap first.

Mine had exactly this issue, exacerbated in the cold weather when the compressor is not active.

Its a 10 minute job to check (and "fix").
Remove the wipers, then remove the scuttle panel (the black plastic grill under the windscreen). Careful how you remove as there are plastic bits that can snap off if you are not careful.
Once removed you will see an intake around the centre, underneath the windscreen. Turn the ignition on and get someone to press the recirc button on and off. If this doesnt do anything then it is goosed. To fix I simply opened the flap and tied it open with some gardening wire. The problem went instantly. And I mean literally 50m down the road it cleared and I never had an issue again. Admittedly going in tunnels you cant shut the thing but I didnt notice in the next 2 or 3 years I had the car
Thanks for that. So today I took off the scuttle panel and had a look at the flap. B it was open. I got the missus to hit the recirc button a few times and there was no change

So I then couldn't figure out how to tie the thing open. I had cable ties and red electrical wire at the ready but I couldn't find anywhere to hook it on so this has me a little stuck now.

I've abandoned ship for today but will have a go at again tomorrow. Any further advice on how to tie the flap open would be much suh appreciated. Thanks!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

VinylHogger is offline Reply With Quote Quote 
Old 01-02-2015   #12
Join Date: Apr 2006
Location: Belfast
Posts: 147
Thanks: 1
Trader Rating: 0
United Kingdom 
Re: Urgent help needed! Windscreen demister not working!

OK, so I've now managed to wedge the recirc flap open. This took a little improvisation so I've used a wooden (wedge shaped) door stop. It fits snuggly in the front right corner so hopefully this will fix it.

Haven't taken it for a test drive as yet so we'll see!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

VinylHogger is offline Reply With Quote Quote 
Old 02-02-2015   #13
Loving my T-Jet Sport
 
deebo007's Avatar
Join Date: Feb 2014
Location: Lichfield
Posts: 62
Thanks: 4
Trader Rating: 0
deebo007 has donated!
United Kingdom 
Re: Urgent help needed! Windscreen demister not working!

Quote Originally Posted by VinylHogger View Post
Thanks for that. So today I took off the scuttle panel and had a look at the flap. B it was open. I got the missus to hit the recirc button a few times and there was no change

So I then couldn't figure out how to tie the thing open. I had cable ties and red electrical wire at the ready but I couldn't find anywhere to hook it on so this has me a little stuck now.

I've abandoned ship for today but will have a go at again tomorrow. Any further advice on how to tie the flap open would be much suh appreciated. Thanks!
Hmmm, if it was open then that's not an issue is it? If it's stuck closed then you will be permanently recirculating the air inside the car which would cause the misting. Would definitely try the pollen filter next.
__________________
MY59 Bravo Sport, 1.4 T-Jet (150), 18" Alloys, Climate, Xenons, Skydome, Arm Rest, Maserati Blue. Love it!
deebo007 is offline Reply With Quote Quote 
Old 02-02-2015   #14
Join Date: Apr 2006
Location: Belfast
Posts: 147
Thanks: 1
Trader Rating: 0
United Kingdom 
Re: Urgent help needed! Windscreen demister not working!

Quote Originally Posted by deebo007 View Post
Hmmm, if it was open then that's not an issue is it? If it's stuck closed then you will be permanently recirculating the air inside the car which would cause the misting. Would definitely try the pollen filter next.
Yeah that did cross my mind but at the same time, the recirc button wasn't working so I don't know if it's possible for the flap to jam itself closed at some point. Either way their is a door stop stuffed in there at the moment. Will try pollen filter next as this is probably overdue anyway!

Cheers
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

VinylHogger is offline Reply With Quote Quote 
Old 27-11-2017   #15
Join Date: Nov 2017
Posts: 8
Thanks: 0
Trader Rating: 0
Hungary 
Re: Urgent help needed! Windscreen demister not working!

Quote Originally Posted by PROV View Post
Yes its been said but I Would check the air recirc flap first.

Mine had exactly this issue, exacerbated in the cold weather when the compressor is not active.

Its a 10 minute job to check (and "fix").
Remove the wipers, then remove the scuttle panel (the black plastic grill under the windscreen). Careful how you remove as there are plastic bits that can snap off if you are not careful.
Once removed you will see an intake around the centre, underneath the windscreen. Turn the ignition on and get someone to press the recirc button on and off. If this doesnt do anything then it is goosed. To fix I simply opened the flap and tied it open with some gardening wire. The problem went instantly. And I mean literally 50m down the road it cleared and I never had an issue again. Admittedly going in tunnels you cant shut the thing but I didnt notice in the next 2 or 3 years I had the car
Hy,
thanks for this awesome tutorial
I've opended the flap in the intake, but the air coming out of the winscreen vents still not so strong as the front vents. Is it a normal symptom?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by urobee; 27-11-2017 at 20:33.
urobee is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Demister not working Lifeson 500 12 22-10-2013 13:24
(T) Windscreen demister krisat56 Bravo 1 14-11-2011 09:46
(G) Rear demister not working mzhussein Punto (Mk2/2b) 3 13-09-2008 19:01
(T) Windscreen Demister Vents Warped.. Andy Monty Grande Punto 4 08-03-2007 13:15