Register Login
The UK's No.1 Chrysler Owners Forum
Reply
 
Thread Tools
Old 30-05-2008   #1
Join Date: May 2008
Posts: 26
Thanks: 0
Trader Rating: 0
United Kingdom 
Bravo 1.2 accelerating lag

I have an 02 Bravo 1.2 and am having problems with a lag when accelerating. I have searched the forum but havent come across any solutions so wondered if anyone could help. Being about as untechnically minded as anyone could be it might be something simple.

Under about 2500rpm the engine stutters as if its going to stall and causes a lag that lasts for a few seconds or until its picked up more rpm. It happens through the gears, so it feels like its almost stalling even in 5th.

The engine management light then comes on, sometimes flashing sometimes constant, depending on what it feels like.

I have tried using redex in case its something to do with the fuel system but its actually made it worse and it seems to be worsening every day.

Has anyone any ideas before I either push it in the canal or give my life savings to a fiat garage,

Cheers,
MH
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

mostlyharmless is offline Reply With Quote Quote 
Old 30-05-2008   #2
Telford's Own...
 
Ffoxy's Avatar
Join Date: Apr 2007
Posts: 9,824
Thanks: 373
Trader Rating: 0
Ffoxy has donated!
United Kingdom 
Re: Bravo 1.2 accelerating lag

The last service was when? Try plugs if they are old, failing that maybe a coilpack, lead breaking down under heavy load...
__________________
Ex Suzuki SV1000S jockey, now a former 1.9 MJet Grande Punto Sporting pilot curently driving a Hyundai i30 1.6 Premium.
Ffoxy is offline Reply With Quote Quote 
Old 30-05-2008   #3
Join Date: May 2008
Posts: 26
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: Bravo 1.2 accelerating lag

Its been serviced about a month ago and had the plugs replaced and things, and ran maginally better for a time but that has worn off now, I will look up that other part you mentioned though.

When I mentioned it to the guy in fiats parts dept he suggested a solution would be to get a mazda instead haha.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

mostlyharmless is offline Reply With Quote Quote 
Old 31-05-2008   #4
Get busy livin'
 
klemster's Avatar
Join Date: Aug 2006
Location: Co. Cork
Posts: 939
Thanks: 34
Trader Rating: 0
klemster has donated!
Ireland 
Re: Bravo 1.2 accelerating lag

1)
If the plugs have been replaced then make sure the leads are ok, next thing is the coil pack. By stuttering I think you mean it has a miss-fire and the flashing engine management light usually means damage to the cat so driving it probably isn't a good idea if you don't want to do anymore damage. A coil pack is quite expensive new so you could get a secondhand one but the thing with that is you don't know how long it is going to last.

2)
Parts guy= fool! You should be in the garage talking to the mechanics. If I bring my car into the dealership I always talk to the foreman so I know what exactly is going on. I have a pretty good relationship with the garage, even got to drive the owner's 500!!
__________________
My Bravo
klemster is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) bravo pulls to right when accelerating!! jpegg81 Bravo / Brava 3 10-02-2008 22:47
Lag on live? vtec Gaming 4 07-10-2007 22:54
(T) why the lag??? boosta Coupe 18 26-11-2006 20:37
why the lag??? boosta Leisure Lounge 6 09-11-2006 22:21
(T) Throttle lag EvilJaxx Cinquecento / Seicento 9 10-08-2005 01:40