Register Login
The UK's No.1 Chrysler Owners Forum
Reply
 
Thread Tools
Old 13-07-2005   #1
Join Date: Jul 2005
Posts: 1
Thanks: 0
Trader Rating: 0
Climate Control problem

Has any one had experience of the Ulysse Mk1 1997/8 climate control system failure.
The symptoms are no lights or display or display backlite on the ECU located below the radio and left of the gearbox. I have removed and dismantled the ECU which consists of two PCBs, one provides the display and switch control, the other contains the microprocessor and is connected to the vehicle wiring loom. I have checked with a meter and found 12V on the input connector regardless of the state of the ignition key switch. I would have expected a pick voltage to instruct the ECU to power up, therefore I don't know if the problem is the ECU or not.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Pmart is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) Climate control - how do you use it? DOG Stilo 29 18-04-2015 12:18
(T) Climate control - cold air only on drivers side? pc99 Stilo 41 18-08-2010 11:55
(T) Creaking Climate Control jasper Stilo 1 28-10-2004 10:14