Technical Clutch pedal and neutral position learning failed avec ECU remapping

Currently reading:
Technical Clutch pedal and neutral position learning failed avec ECU remapping


New member
Apr 18, 2024
Hello everyone,

I had reprogrammed my car to E85 and stage 1 by the MTD team (a globally renowned team for multi airs). I just took a spin in Multi Ecu Scan because my engine light was flashing, and I saw that I needed to redo a phonic wheel learning, which I was able to do through the dedicated procedure.

However, I still have two faults:

P080A-55 / Clutch pedal learning
P1306-55 / Neutral signal learn.

From what I understand after some digging, the second fault should only be resolved if there are no other engine faults, so I'm trying to address the first one. Clearing the codes doesn't change anything; I even did a complete ECU reset and relearning, but it doesn't change anything. I thought simply pressing the clutch pedal all the way would correct this fault, but it doesn't seem to change anything after several attempts...

I tried to do the neutral position learning with MES and it failed (it told me the condition was no OK, my car was OFF, MAR ON...), it tried with ALFA OBD using the good ECU and it told me approximatively the same " values are outside allowable range" ( yeah, i was in neutral position).

I was wondering if any pros here might have an idea. Of course, I've sent an email to my mapping team, awaiting updates.

Any ideas please ?

Thanks a lot.
Hello guys

Some news after lot of try....

Still not able to do the two learning with MES or Alfa OBD > Error > values under bad contion to run this test : In MES :


In Alfa Obd :

However, I flashed my file again with Kess (clone) and noticed something strange : once the progress bar reaches 100% during the flash, Kess asks me to turn the ignition on and off several times, without requesting anything else. Once everything is done, I still have my two current errors.

If I flash again, and once it reaches 100%, if I keep the clutch pressed, Kess asks me to press the clutch and then press OK, after which it asks me to release it... and it goes through a "learning" process again.

However, at the end, instead of getting a "success" message, I get an "Error UM 00:000".

If I then go into MES, I only have the neutral point fault to learn, the one related to clutch pedal learning is no longer there, so I feel like the post-flash procedure in kSuite (on protocol 532) is incorrect.

I've tested 3 different versions of KSUITE, and they all behave the same way.

Similarly, if I go to Tool, and delete errors (still in KSUITE), on protocol 532, it just makes me do ON/OFF cycles and never asks me to press the clutch, even though it should....

That's why I think it's a configuration problem with protocol 532 with the clone.

Any ideas on things to try?

Thank you