Register Login
endrop - for all your online needs
Reply
 
Thread Tools Search this Thread
Old 08-10-2003   #1
Join Date: Jun 2003
Location: Chesterfield, United Kingdom.
Posts: 924
Thanks: 0
Trader Rating: 0
bloody speakers!

I was just checking that all my speakers in the car were screwed in tightly last night when I discovered that one of the two ways in the back had gone! The tweeter works fine but the woofer has gone! Im going to have to make some grills for the fronts too, the screws holding them in have gone cock-eyed and bent the grills as they have been screwed in, looks a mess now!

Going to get some Sony Xplod (dont laugh! I only want them because theyre red! to match the car) co-axials for the front and put the old (working) speakers out the front into the back. and make some new grills out of 9mm MDF and paint them black for the front. Can anyone think of any problems I will find?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Sando is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
New speakers sound awful Trebor I.C.E 5 23-03-2004 17:49
(G) Cinq Door Speakers DJ_Bucho Cinquecento / Seicento 4 17-02-2004 06:54
New Speakers and Sub sh33n I.C.E 25 13-02-2004 16:28
problem installing my new Speakers sparky762 I.C.E 3 16-01-2004 22:47
Replacing Factory Fit Speakers lankman_007 I.C.E 8 12-03-2003 15:27