Register Login
endrop - for all your online needs
Reply
 
Thread Tools
Old 23-01-2005   #1
Join Date: Aug 2003
Location: Fife
Posts: 1,242
Thanks: 6
Trader Rating: 0
United Kingdom 
Window washers not spraying properly

This started with the rear wiper, which I just put down to it being on the way out. and that I hadnt made an effort to sort yet.
What happens with the rear wiper is that it wont spray any window wash unless the wiper has been turned on first. Doesnt even make the motor noise unless the wiper is moving now.
Now I noticed this is starting to happen at the front as well. Not as frequient but it has started this week.
When I tried the front ones, I sometimes heard a click from the relay box under the stearing wheel area, only when it did manage to spray.
So just wondering really if it could just be a faulty relay ?
__________________
Scorg
Scorg is offline Reply With Quote Quote 
Old 23-01-2005   #2
Join Date: Jan 2004
Location: stourbridge United Kingdom.
Posts: 152
Thanks: 0
Trader Rating: 0
Cool Re: Window washers not spraying properly

now this could be me,ive gone through the wiring diagramas and i dont see a relay for the wash system.the rear works off the main bootle/same as per front,as do most new cars these days.ie no seperate bootle and pump.but the rear works harder.further to pump it.id check 2 things.1 rub the contacts on the boot with sand paper.then id check the pump itself. a test lamp or meter will tell you if the circuit is ok.failing this it could be the switch.now dont think im taken the p**s but you sure it aint frozen up.the jets that is not the water.it being cold and all.rich.
__________________
if it aint broke dont fix it.purple pain.up the villa.brava 1.6sx.
no fag.lighter required.its good too no that you will be home for christmas.
rich. is offline Reply With Quote Quote 
Old 24-01-2005   #3
Join Date: Aug 2003
Location: Fife
Posts: 1,242
Thanks: 6
Trader Rating: 0
United Kingdom 
Re: Window washers not spraying properly

Quote Originally Posted by rich.
now this could be me,ive gone through the wiring diagramas and i dont see a relay for the wash system.the rear works off the main bootle/same as per front,as do most new cars these days.ie no seperate bootle and pump.but the rear works harder.further to pump it.id check 2 things.1 rub the contacts on the boot with sand paper.then id check the pump itself. a test lamp or meter will tell you if the circuit is ok.failing this it could be the switch.now dont think im taken the p**s but you sure it aint frozen up.the jets that is not the water.it being cold and all.rich.
definetly isnt the last one, as they start to spray as soon as the wipers are turned on. front ones arnt too bad, 90% of the time they will spray, just the rest of the time it wont unless ive turned the wipers on. its all the time on the rear. The rear doesnt even get the pump noise when you just give the wiper control a push either, again only when the wipers on will it do that.
I had a look in the manual for a relay too, but it doesnt refer to what the relays are behind the glovebox.

Ive given the rear contacts a wipe, but only with a kitchen towel to wipe any muck off them, didnt make any difference. Since there isnt a relay im guessing its either the switch or pump, or maybe something amis on the circuit.
__________________
Scorg
Scorg is offline Reply With Quote Quote 
Old 24-01-2005   #4
Join Date: Jan 2004
Location: stourbridge United Kingdom.
Posts: 152
Thanks: 0
Trader Rating: 0
Re: Window washers not spraying properly

the 3 relays are 4 .igntion discharge.horn.heated screen.to test your motor,remove it conect it to a small battery such as 4 lardger tourches if it runs like a good un you no its ok.you can then look at the switch.you may also like 2 try clearing the jets with a needle.just dont snap it in there.
__________________
if it aint broke dont fix it.purple pain.up the villa.brava 1.6sx.
no fag.lighter required.its good too no that you will be home for christmas.
rich. is offline Reply With Quote Quote 
Old 25-01-2005   #5
Join Date: Aug 2003
Location: Big-Les-Wade
Posts: 794
Thanks: 5
Trader Rating: 0
Space Invaders Champion
United Kingdom 
Re: Window washers not spraying properly

Oh dear! Sorry Scorg but this sounds like the trusty old stalk problems again. Usually, strange things going on with stalk functions are down to faulty stalks chap.

This isn't a definite but may be that you need to give the connections a clean at the steering wheel end.
__________________
Doctor said to give up Keee-babs. I said, "No, no-no"
Ozric-Al is offline Reply With Quote Quote 
Old 25-01-2005   #6
Join Date: Aug 2003
Location: Fife
Posts: 1,242
Thanks: 6
Trader Rating: 0
United Kingdom 
Re: Window washers not spraying properly

Quote Originally Posted by Ozric-Al
Oh dear! Sorry Scorg but this sounds like the trusty old stalk problems again. Usually, strange things going on with stalk functions are down to faulty stalks chap.

This isn't a definite but may be that you need to give the connections a clean at the steering wheel end.
Think im just going to book it into the garage, got a warrenty on it so may as well use it.

damn, I love having an italian car again, all the quirky problems
__________________
Scorg
Scorg is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Electric Window plastic part. Felipe Doblo 2 25-01-2005 02:23
(S) Removing rear window Adamski Cinquecento / Seicento 2 28-10-2004 19:36
(T) Fiat tipo window washers excossack Tipo (Classic) 1 09-09-2004 11:00
(G) window washers blackJTD Stilo 8 13-05-2004 01:41
(T) Electric window jambo Punto (Mk1) 7 09-08-2003 21:39