Register Login
Mr FIAT - Your #1 source for vintage car parts
Reply
 
Thread Tools
Old 1 Week Ago   #1
Join Date: May 2018
Location: NYC
Posts: 3
Thanks: 0
Trader Rating: 0
USA 
Need help with Alpine Double Din Receiver install and iDatalink Maestro

Hello everyone, I've arrived at a road block with my double din receiver install on a 13 Abarth. I ordered an Alpine iLX-207 in-dash receiver as well as the iDatalink Maestro RR Interface module and the iDatalink Maestro Plug and Play Installation Harness as well as the double din dash kit.

My first probelm was after all the correct wires had been connected and the harness and receiver installed I was getting no power. The continuity all checked out and the car was giving power from its original power source for our radio. So I checked to see if I was getting accessory power from any wire source when I would turn on the car and I wasn't. I decided to do a fuse tap to our 10amp fuse that powers our radio and climate control and that gave succesful power to the reciver; only problem was that the receiver would always stay on even when the car was off and locked. I still proceded with the install only to have another problem, there's no audio coming out of the speakers now. The connections of the harness to the front, rear and subwoofer are correct but no audio is coming out at all.

Summary:

How to get power to receiver?
Is fuse tap for accessroy power necessary?
Where to get accessory power?
No audio coming from the speakers, issues could be?

I've checked continuity and all the connections are good, I've checked the wiring and they are all as should be with exception of the fuse tap red wire, which I had to do because the unit wasn't turning on at all. And I've reattached the factory radio to check the audio and it works fine.
Thanks, any help appreciated.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

rich7 is offline Reply With Quote Quote 
Old 1 Week Ago   #2
Join Date: Dec 2014
Location: Orpington, Kent UK
Posts: 1,733
Thanks: 101
Trader Rating: 0
United Kingdom 
Re: Need help with Alpine Double Din Receiver install and iDatalink Maestro

This is a simplistic idea, but I had exactly the same problem with my Xtrons double din for my Nissan Juke. I contacted the manufacturer and they told me to swap the yellow and red wires, I.e making the permanent live ignition live and vice versa. To my amazement it worked.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

typecastboy is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Double Din Stereo, not sure how to install it... tibrocks Panda 4 24-11-2015 15:07
Fiorino Single din to double din stereo install. Rich181 I.C.E 0 07-05-2015 20:09
(T) Replacing Blaupunkt Double Din unit for JVC Single Din Stereo art101 Panda 1 24-04-2014 07:24
(G) Double DIN or DIN? dunks Grande Punto 2 04-07-2010 23:20
H3 Head unit: 1 x DIN or Double DIN? stretch3144 I.C.E 0 19-09-2008 19:28