Register Login
The UK's No.1 Chrysler Owners Forum
Reply
 
Thread Tools
Old 15-11-2018   #1
Join Date: Nov 2018
Posts: 1
Thanks: 0
Trader Rating: 0
United Kingdom 
Uconnect help

Hi all,

Forum Noob here!

I bought a 2014 Fiat 500L from a car auction 3 weeks ago. Car is lovely nice drive. The Uconnect system was great until:

Driving to Wales this Friday just gone. Uconnect working just fine. Stop to fill the tank up. When I fire up the engine again the Uconnect system shows the Fiat logo, nothing else. It doesn't show the usual driving warning notice that you hit agree too. Now as we weren't needing the music on or anything my little one was falling asleep in the back I didn't think anything of it. About an hour later into the drive I decided that the FIAT logo on the screen was annoying me in the dark so I hit the power button and it turned off.

The next day the Uconnect system did not power up again, dead. None of the buttons do anything. If you hit the CD eject button you hear it trying to eject a disk that isn't there suggesting there is power.

Since then I have tried unplugging the battery and leaving it for over an hour. Still nothing. Checked the fuse. Seems fine.

Oddly enough my wife mentioned that when she fueled up again the FIAT logo appeared again but eventually disappeared.

Local FIAT dealer want £114 just to diagnose the issue. I'd rather avoid that if I can!

Does anyone have any ideas as to what this could be? Any suggestions welcome. No in car entertainment as it stands.

Just to clarify there are no other electrical issues at all with the car. Just the Uconnect.

I believe from googling it is a Uconnect 5.0


Cheers!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by jammessi; 15-11-2018 at 14:54. Reason: adding in the Uconnect type
jammessi is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Uconnect problem JoBoxer 500X 7 26-07-2018 23:35
(T) UConnect misssarahf86 Tipo 1 07-05-2018 08:51
(G) UConnect Leatherlip 500 4 19-04-2018 15:01
(T) uConnect nd1986 500 3 10-11-2017 10:28
From Uconnect live to Uconnect Tom Tom GPS Tiagovarela25 Satellite Navigation 0 20-12-2016 18:25