Register Login
Mr. FIAT
Reply
 
Thread Tools
Old 08-03-2012   #1
Join Date: Mar 2012
Posts: 2
Thanks: 0
Trader Rating: 0
Ireland 
Windscreen wiper problems

I just got a 2002 Fiat Punto for my daughter. When she pushed the rear washer switch forward, it blew the fuse for both front and rear wipers. I have checked both the motor and pump and both seem to be fine. Is it possible that a faulty switch is causing this, appreciate the help.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

Crazydad is offline Reply With Quote Quote 
Old 08-03-2012   #2
Telford's Own...
 
Ffoxy's Avatar
Join Date: Apr 2007
Posts: 9,834
Thanks: 373
Trader Rating: 0
Ffoxy has donated!
United Kingdom 
Re: Windscreen wiper problems

Pop a new fuse in after you have unplugged both motors, see if it blows again, if it does it could be the switch or a wiring short.

If it doesnt its possible you have a motor problem, is the front wiper linkage in good order & both spindles free to move... these often rust solid.
__________________
Ex Suzuki SV1000S jockey, now a former 1.9 MJet Grande Punto Sporting pilot curently driving a Hyundai i30 1.6 Premium.
Ffoxy is offline Reply With Quote Quote 
Old 08-03-2012   #3
Join Date: Mar 2006
Location: Liverpool
Posts: 26,644
Thanks: 1174
Blog Entries: 3
Trader Rating: 5
fingers99 has donated!
United Kingdom 
Re: Windscreen wiper problems

And try isolating one motor at a time.

I can't remember how these are wired up. One fuse, I think, but motors are switched independently? Which would put the fault (possibly) with the rear motor?
__________________
M12 fund 20
fingers99 is offline Reply With Quote Quote 
Old 08-03-2012   #4
Join Date: Mar 2006
Location: Liverpool
Posts: 26,644
Thanks: 1174
Blog Entries: 3
Trader Rating: 5
fingers99 has donated!
United Kingdom 
Re: Windscreen wiper problems

And try isolating one motor at a time.

I can't remember how these are wired up. One fuse, I think, but motors are switched independently? Which would put the fault (possibly) with the rear motor?
__________________
M12 fund 20
fingers99 is offline Reply With Quote Quote 
Old 09-03-2012   #5
Join Date: Mar 2012
Posts: 2
Thanks: 0
Trader Rating: 0
Ireland 
Re: Windscreen wiper problems

Hi, thanks for the replies, I have tried both possible solutions and problem still there, it only happens when you push the switch forward to activate the rear washer.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

Crazydad is offline Reply With Quote Quote 
Old 09-03-2012   #6
Join Date: Mar 2006
Location: Liverpool
Posts: 26,644
Thanks: 1174
Blog Entries: 3
Trader Rating: 5
fingers99 has donated!
United Kingdom 
Re: Windscreen wiper problems

Locate rear washer motor (no idea where on Puntos!), pull the connector(s) off it, replace fuse, try again. If the fuse blows, you've a short between the push and the motor. Otherwise, look to the motor itself.
__________________
M12 fund 20
fingers99 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Problems with getting the windscreen wiper off of the spindle of a Punto Spoult Punto (Mk2/2b) 3 11-01-2010 19:23
(G) Help - Windscreen Wiper problems thepages975 Bravo / Brava 6 14-05-2008 08:22
(T) windscreen wiper not wiping the windscreen Donnie Darko Grande Punto 14 17-12-2006 23:21
(G) Windscreen Wiper chrisunoman Uno 3 02-08-2004 11:40