Register Login
Save up to 15% with Adrian Flux insurance!
Reply
 
Thread Tools
Old 2 Weeks Ago   #1
Join Date: May 2010
Posts: 1,507
Thanks: 188
Trader Rating: 0
Goudrons has donated!
United Kingdom 
Idle problem - running on

To add to my rattly steering rack, I've now another issue with the Pop.

It's been hanging onto revs on the over run.
Not every time, but it did it three times in a short trip (3 miles) this afternoon.

Approach a junction or slow down by taking my foot off the gas or take my foot off to brake and it's started to hang on to the revs.
Instead of slowing on the over run, it's powering me along stuck with around 2000 rpm on it.

I original thought I might be catching the accelerator pedal slightly with my shoe when braking as that's what it feels like, but it's definitely not that.

Once I've jammed on the brakes and pulled it up, it returns to normal either straight away or within a second or two.

No EML and I've not tried a code read yet, but I can only think it's the TPS or pedal potentiometer?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Goudrons is offline Reply With Quote Quote 
Old 2 Weeks Ago   #2
Moderator
 
g8rpi's Avatar
Join Date: Nov 2013
Location: Cambridge
Posts: 2,208
Thanks: 169
Trader Rating: 0
g8rpi has donated!
United Kingdom 
Re: Idle problem - running on

Most likely the pedal is sticking or catching on a mat or trim. Could be the pedal potentiometer but it's a dual unit so should detect an electrical failure. Could be a worn coupling between pedal and potentiometer. Unlikey to b the throttle servo as a mismatch between command and position should cause a failure light.

Robert G8RPI.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

g8rpi is offline Reply With Quote Quote 
Old 2 Weeks Ago   #3
Join Date: May 2010
Posts: 1,507
Thanks: 188
Trader Rating: 0
Goudrons has donated!
United Kingdom 
Re: Idle problem - running on

I'm certain it's not getting stuck on a mat, there aren't any.

I'll try a code read once I find the socket!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Goudrons is offline Reply With Quote Quote 
Old 2 Weeks Ago   #4
Moderator
 
g8rpi's Avatar
Join Date: Nov 2013
Location: Cambridge
Posts: 2,208
Thanks: 169
Trader Rating: 0
g8rpi has donated!
United Kingdom 
Re: Idle problem - running on

Quote Originally Posted by Goudrons View Post
I'm certain it's not getting stuck on a mat, there aren't any.

I'll try a code read once I find the socket!
Hi,
The OBD socket should be behind a plastic trim panel between the steering column and door post. There are a couple of screws at the bottom edge of the panel. Socket is normally black with a yellow centre.


Robert G8RPI.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

g8rpi is offline Reply With Quote Quote 
Old 2 Weeks Ago   #5
2014 Panda Lounge 1.2
 
murphyv310's Avatar
Join Date: Aug 2010
Location: Kilmarnock
Posts: 504
Thanks: 27
Trader Rating: 0
murphyv310 has donated!
murphyv310 is an honorary friend of the forum :)
United Kingdom 
Re: Idle problem - running on

Worth giving the throttle body a clean with carb or brake cleaner, my throttle flap was quite gummy and a little slow in responding to me lifting off, fine after a wash!!!
Likes jrkitching liked this post
__________________

Cheers Trevor
murphyv310 is offline Reply With Quote Quote 
Old 2 Weeks Ago   #6
Join Date: May 2010
Posts: 1,507
Thanks: 188
Trader Rating: 0
Goudrons has donated!
United Kingdom 
Re: Idle problem - running on

I've found no codes stored, so I unplugged the connectors to the pedal, throttle body and ECU, cleaned them up with contact cleaner.

I took it out for a spin and it seemed to drive ok again.

Only thought after to check the state of the TB's butterfly and MAP.
As others have found, the MAP had a coating of oil and the TB's mouth was pretty grubby, so they got a clean as well.

Time will tell if it's cured or not, fingers crossed.
Likes murphyv310 liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Goudrons is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) FIAT CINQUECENTO not running past idle mark850 Cinquecento / Seicento 26 25-07-2009 05:00
(G) idle running rendar Punto (Mk2/2b) 1 15-03-2008 10:26
(T) seicento running ok at idle but smokes andy majorca Cinquecento / Seicento 1 12-06-2007 22:23
(G) Engine is running unstable at idle speed. Lyche Marea 6 15-01-2007 20:50
TD 100 SX Running Idle seve FIAT Boo Archives 0 09-03-2003 22:09