Register Login
iNETFX Domain Registration - COM/NET/ORG 6.50 a year!
Reply
 
Thread Tools
Old 27-04-2009   #1
Join Date: Apr 2009
Posts: 1
Thanks: 0
Trader Rating: 0
Cool MK1 Punto Temp Gauge not working

Am now the proud owner of a Mk1 Punto 60S Team (T reg (June 1999 1st Reg) with a mere 80k miles on the clock. My problem is that the temp gauge does not move. Have replaced the temp sender unit, no change. When you short out the single wire to the engine block the gauge moves right to max, so that's working. The engine is warming up and does not appear to be overheating, there's water in the coolant reservoir. So does any one have any suggestions as to what to try next? The Haynes workshop manual is not much help! Any one got one of these books? My punto is a 1.2 but the photo in their book looks more like the 1.1, ??? Hey Ho! Thanks in teh hope someone has been able to cure this before.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

Roundakela is offline Reply With Quote Quote 
Old 27-04-2009   #2
Join Date: Mar 2008
Posts: 1,049
Thanks: 95
Trader Rating: 0
United Kingdom 
Re: MK1 Punto Temp Gauge not working

Do the heaters get hot after a 15-20 min journey?

could be a stuck thermostat or the previous owner has taken the thermostat out.
__________________

Mdeko is offline Reply With Quote Quote 
Old 27-04-2009   #3
MK1 Punto Mad
 
01goddak's Avatar
Join Date: Apr 2008
Location: Reading
Posts: 558
Thanks: 32
Trader Rating: 0
01goddak has donated!
United Kingdom 
Re: MK1 Punto Temp Gauge not working

as far as im aware.. the s doesn't come as standard with a temp guage .. where the temp sender is there is/was two sizes a 19mm bolt and a 22mm bolt i belive the smaller one is used with the gauges with no rev counter and the bigger is used for the ones witha rev counter .. did you replace it with the correct variation of the sender?? thats m guess
01goddak is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) mk1 s temp gauge will4318 Punto (Mk1) 3 29-04-2007 10:46
(T) Problem with temp gauge on punto mk1 PuntoMkey Punto (Mk1) 1 10-01-2007 17:14
(T) Punto MK1 rev. counter and temp gauge sr3309 Punto (Mk1) 3 14-01-2005 17:11
(G) Temp gauge not working Cliff White Cinquecento / Seicento 3 11-04-2004 04:22