Register Login
FIAT Auto Specialist Team
Reply
 
Thread Tools
Old 13-03-2011   #1
Join Date: Mar 2011
Posts: 1
Thanks: 0
Trader Rating: 0
South Africa 
Fiat Palio Weekend 1.6EL not starting

We bought said car about a year ago. Recently, we have had problems with the car that it doesn't have power when pulling away. I had to literally rev the engine so it won't stall. I felt like an idiot at every traffic light and stop street.

Anyways, a week ago, the car cut out and I couldn't get it started again. Hubby towed car home and we asked a mechanic what could be the problem. He said to replace the fuel filter, which we did. But the car still won't start. We have replaced the spark plugs too, as the mechanic said maybe some of the spark plugs aren't working properly. (We just had the car at the mechanic middle Feb as the cambelt needed to be replaced so we can't afford to have him look at the car again right now.)

The engine turns. But it just won't start.

Also, I noted at times (not always) that the headlights (and accordingly dashboard light) would come on. And this whilst the engine and the lights are off??

Please help.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

HotChocolate is offline Reply With Quote Quote 
Old 13-03-2011   #2
Moderator
 
Peter Pick-Up's Avatar
Join Date: Mar 2008
Posts: 2,623
Thanks: 114
Trader Rating: 0
Peter Pick-Up has donated!
Netherlands 
Re: Fiat Palio Weekend 1.6EL not starting

Have a look at the timing of the new belt, looks like it slipped one or more theeth.....??
Ask the mechanic that did the cambelt job.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

Peter Pick-Up is offline Reply With Quote Quote 
Old 13-05-2011   #3
Join Date: Sep 2009
Location: Cape Town
Posts: 2
Thanks: 0
Trader Rating: 0
South Africa 
Re: Fiat Palio Weekend 1.6EL not starting

Quote Originally Posted by HotChocolate View Post
We bought said car about a year ago. Recently, we have had problems with the car that it doesn't have power when pulling away. I had to literally rev the engine so it won't stall. I felt like an idiot at every traffic light and stop street.

Anyways, a week ago, the car cut out and I couldn't get it started again. Hubby towed car home and we asked a mechanic what could be the problem. He said to replace the fuel filter, which we did. But the car still won't start. We have replaced the spark plugs too, as the mechanic said maybe some of the spark plugs aren't working properly. (We just had the car at the mechanic middle Feb as the cambelt needed to be replaced so we can't afford to have him look at the car again right now.)

The engine turns. But it just won't start.

Also, I noted at times (not always) that the headlights (and accordingly dashboard light) would come on. And this whilst the engine and the lights are off??

Please help.
Just had a similar experience with 1,6 Weekend. The car would be fine while cold but when warm it would cut out. Took it to Italian car experts Auto Azzuri and turned out to be the coil pack failing when it gets hot. Cost us R1200.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

peterdpalm is offline Reply With Quote Quote 
Old 31-05-2011   #4
Join Date: Sep 2009
Location: Cape Town
Posts: 2
Thanks: 0
Trader Rating: 0
South Africa 
Unhappy Re: Fiat Palio Weekend 1.6EL not starting

Ok, after replacing the coil pack, the car was still cutting out, so they replaced the fuel pump relay and a sensor, I think the knock sensor. That cost another R1200 but now it seems fine. So it appears that these three items are all likely culprits on the 1,6 Palio.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

peterdpalm is offline Reply With Quote Quote 
Old 31-05-2011   #5
Moderator
 
Peter Pick-Up's Avatar
Join Date: Mar 2008
Posts: 2,623
Thanks: 114
Trader Rating: 0
Peter Pick-Up has donated!
Netherlands 
Re: Fiat Palio Weekend 1.6EL not starting

No, not all three together at one single car.
Seems to me, your mechanic didn't know where to look for, and just started to change things that MIGHT be the problem.
I suspect only the faulty sensor.....!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

Peter Pick-Up is offline Reply With Quote Quote 
Old 01-06-2011   #6
Join Date: Apr 2011
Posts: 252
Thanks: 7
Trader Rating: 0
United Kingdom 
Re: Fiat Palio Weekend 1.6EL not starting

Is palio running same 1.6 as marea and bravo?

Map sensor can do this to our poor cars :P,

Cleaned mine with spirits, problem solved!
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

MrMigs08 is offline Reply With Quote Quote 
Old 01-06-2011   #7
Moderator
 
Peter Pick-Up's Avatar
Join Date: Mar 2008
Posts: 2,623
Thanks: 114
Trader Rating: 0
Peter Pick-Up has donated!
Netherlands 
Re: Fiat Palio Weekend 1.6EL not starting

Same engine.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

Peter Pick-Up is offline Reply With Quote Quote 
Old 01-06-2011   #8
Join Date: Apr 2011
Posts: 252
Thanks: 7
Trader Rating: 0
United Kingdom 
Re: Fiat Palio Weekend 1.6EL not starting

Yep, i would have said map to that issue, although a faulty knock sensor could make the car run strange.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

MrMigs08 is offline Reply With Quote Quote 
Old 20-07-2011   #9
Join Date: Mar 2011
Posts: 18
Thanks: 0
Trader Rating: 0
India 
Re: Fiat Palio Weekend 1.6EL not starting

It could be a faulty crank position sensor. we had this issue with my friends car the engine crank up but it wont start. Disconnected the fuel hose and put the ignition on, fuel erupts like a volcano. This eliminated faulty relay or pump. Checked the ign coil with a digital multimeter and it was good. The next thing we went ahead and checked was the crank sensor. I fiddled with the sensor socket which sits in front of radiator and a quick spray of wd40 over it. Cranked the engine it purred to life like nothing has happened.

Regards,
Vijay
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

vijaycool is offline Reply With Quote Quote 
Old 19-09-2011   #10
Join Date: Mar 2011
Posts: 4
Thanks: 0
Trader Rating: 0
South Africa 
Re: Fiat Palio Weekend 1.6EL not starting

Dear All

Sorry for the late feedback, but in our case (HC is my wife) it was the crank positioning sensor. Once it was replaced, the car ran fine.

However, another issue has now come up - the welch plug for the cylinder head started to leak due to corrosion. We replaced it in situ, but the replacement part also leaked. So we had to take the head off to send it in to an engineering company for a proper fix and a pressure test. The head is fine.

Whilst removing the head, we also had some issues in removing the last 4th nut on the exhaust manifold (where it couples to the exhaust pipe). It wasted us a whole day. Anyway, it was removed - we replaced all four the studs on the exhaust manifold coupling with new studs.

So... now... what is the correct torquing sequence for the Palio Weekender EL 1600 16valve engine? 4+90+90? It sound too much to me - as you tighten the bolts almost 180 degrees at the end ... What happened to good old tightening by torque?

Kind regards

Libs
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

The Librarian is offline Reply With Quote Quote 
Old 19-09-2011   #11
Moderator
 
Peter Pick-Up's Avatar
Join Date: Mar 2008
Posts: 2,623
Thanks: 114
Trader Rating: 0
Peter Pick-Up has donated!
Netherlands 
Re: Fiat Palio Weekend 1.6EL not starting

Ask in the general "Tech" section on this board,as the 1,6-16V Fiat engines are all the same for every model.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

Peter Pick-Up is offline Reply With Quote Quote 
Old 23-01-2012   #12
Join Date: Mar 2011
Posts: 18
Thanks: 0
Trader Rating: 0
India 
Re: Fiat Palio Weekend 1.6EL not starting

Hi,
I got to see one Adventure(Marea) 1.6 . Its starting of well (1100 rpm) but once warmed up the rpm meter showing as 600 rpm. Hooked up in the scanner it reads 800~840 rpm. When i checked the Knock sensor voltage value it shows as 0.741 V for all cylinders. In my car its showing as 0.451 V. The car shakes and sounds like knocking when i leave the clutch and dies off. No error codes are shown. Is this issue with Knock sensor or crank position sensor?

Regards,
Vijay
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides | FAQs

vijaycool is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Problem with starting the engine palio Weekend 1.2 livius44 Palio 1 15-07-2009 07:40
(G) Is the Fiat Palio Weekend a popular car in the UK? RudyDaCosta Palio 9 20-03-2009 19:22
Fiat Palio Weekend Adventure RobW Leisure Lounge 0 12-08-2002 20:02