Register Login
FIAT Auto Specialist Team
Reply
 
Thread Tools
Old 27-08-2017   #1
Join Date: Jul 2016
Location: Auckland
Posts: 11
Thanks: 0
Trader Rating: 0
New Zealand 
Front Wipers not returning to start position

Hey everyone,

Just a note to start - This is a 1989 Uno Fire 45

Recently about a week ago my front wipers stopped working. After a week of checking connections, the motor, the switch, and earth terminals, suddenly they worked again. Fiat reliability for you.

However, when you stop the wipers now they no longer return to the starting position and just stop wherever they are now even if its in the middle of the windscreen.

First thought would be a relay - But the uno doesn't have one??

Any advice?
Thanks in advance guys
__________________
1989 Fiat Uno 45 Fire
Needs: Paint, Bumper crack, Clutch, Water leak, window wiper spray fixed, a little rust and body repair, an oil cap, a boot strut, and some TLC
Some actual horsepower would be nice sometime too
I love this car to death
JohnWick is offline Reply With Quote Quote 
Old 27-08-2017   #2
Moderator
 
g8rpi's Avatar
Join Date: Nov 2013
Location: Cambridge
Posts: 2,526
Thanks: 205
Trader Rating: 0
g8rpi has donated!
United Kingdom 
Re: Front Wipers not returning to start position

Quote Originally Posted by JohnWick View Post
Hey everyone,

Just a note to start - This is a 1989 Uno Fire 45

Recently about a week ago my front wipers stopped working. After a week of checking connections, the motor, the switch, and earth terminals, suddenly they worked again. Fiat reliability for you.

However, when you stop the wipers now they no longer return to the starting position and just stop wherever they are now even if its in the middle of the windscreen.

First thought would be a relay - But the uno doesn't have one??

Any advice?
Thanks in advance guys
Hi,
There is a switch contact insde the wiper motor that sets the park it is powered with the wiper set to off. There are two possible faults:
1/ Contact in wiper motor faulty
2/ No power to wiper motor in "off" stalk position (faultyl stalk, wiring or connector).

So first thing is to disconnect wiper motor connector, set stalk switch to off , ignition on and check with a voltmeter (or test lamp) for voltage on one of the pins. If there is voltages you need to repair or replace the motor. I don't know the Uno motor but generally there is a cover over the gear box the will expose the contacts. Cleaning the contacts (and possibly slightly bending any sprung arm) may be enough to fix it.
If there is no voltage at the connector it's likey to be the stalk switch but you should check the wiring too.

HTH,
Robert G8RPI.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

g8rpi is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) wipers have jumped position skeggylad Punto (Mk2/2b) 20 09-02-2015 18:31
(T) Front Wipers Upright Park Position Fiat04 Stilo 3 10-02-2011 15:21
(T) Headlight start/finish position? popsprocket X1/9 3 04-01-2010 11:41
(T) Wipers - work fine but stop in upright position pete10 Punto (Mk2/2b) 4 17-01-2009 17:51
Wipers do not park in right position on FIAT Marea 1996 Adi FIAT Boo Archives 0 24-03-2003 09:04