Register Login
FIAT Auto Specialist Team
Reply
 
Thread Tools
Old 31-05-2005   #1
Join Date: Nov 2004
Posts: 11,187
Thanks: 123
Trader Rating: 16
beau has donated!
United Kingdom 
Unhappy horn not working

hi,

my horn is crazy!

one minute works fine, next nothing, and then sudenly when you dont expect it it goes off. why is this?? it seems as though the battery doesnt have enough power sound it, and then charges abit and works again, but if it was the battery wouldnt the car not start? the car starts fine.
__________________

Maserati 3200 GT Coupe
beau is offline Reply With Quote Quote 
Old 31-05-2005   #2
Join Date: Apr 2003
Location: Nottm
Posts: 6,427
Thanks: 0
Trader Rating: 0
The Negotiator has donated!
United Kingdom 
Re: horn not working

They put the horn right where it corrodes nicely and it works randomly. Removed the contacts (under the front bumper) and make sure they are cleaned up etc. It will fix your problem, i had the same problem...
__________________
Now drives: BMW 635d (wow!)
Past:
Renault Laguna Coupe GT 180. Laguna Initiale dci. 52 Megane 1.9dCi, Y-reg Fiat Brava JTD (Pale Blue) (2006), '51 Fiat Brava 80 SX (black) (2006), M-reg UNO (2003-2004)
The Negotiator is offline Reply With Quote Quote 
Old 31-05-2005   #3
Join Date: Jul 2004
Location: LONDON, United Kingdom.
Posts: 696
Thanks: 0
Trader Rating: 0
United Kingdom 
Re: horn not working

Sounds to me like a dodgy connection. Check the connection on the actual horn itself, it may be corroded or loose. Or the horn itself might need to be replaced. And check the fuse as well.

F R O $ T Y
__________________
"It Don't Matter if you win by an inch..or a mile...
Winning is Winning"
F R O S T Y is offline Reply With Quote Quote 
Old 31-05-2005   #4
Join Date: Nov 2004
Posts: 11,187
Thanks: 123
Trader Rating: 16
beau has donated!
United Kingdom 
Re: horn not working

took the connections off the horn under the bonnet, they were rusted up, gave them a clean with wire brush put them back on and it works perfect
__________________

Maserati 3200 GT Coupe
beau is offline Reply With Quote Quote 
Old 01-06-2005   #5
Join Date: Apr 2003
Location: Nottm
Posts: 6,427
Thanks: 0
Trader Rating: 0
The Negotiator has donated!
United Kingdom 
Re: horn not working

See I did learn something from my time owning a Uno
__________________
Now drives: BMW 635d (wow!)
Past:
Renault Laguna Coupe GT 180. Laguna Initiale dci. 52 Megane 1.9dCi, Y-reg Fiat Brava JTD (Pale Blue) (2006), '51 Fiat Brava 80 SX (black) (2006), M-reg UNO (2003-2004)
The Negotiator is offline Reply With Quote Quote 
Old 01-06-2005   #6
Fat pigeon... APPLE!
 
JonnyBoy's Avatar
Join Date: May 2003
Posts: 2,007
Thanks: 5
Trader Rating: 1
JonnyBoy has donated!
United Kingdom 
Re: horn not working

Rip the puny thing off and fit an air horn I want a musical one for the Capri, Del-Boy styleee!
__________________
Past: '91 Uno 45 Formula; '94 Punto 55SX; '58 Bravo 1.9 Multijet (150BHP) Dynamic, with extra toys
Present: Several, but nowt Italian...
JonnyBoy is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(G) Horn stopped working - fuse? Gav Punto (Mk2/2b) 19 27-08-2016 13:49
(T) Horn not working GrahamD Punto (Mk2/2b) 5 26-06-2005 13:55
(T) Horn akkarin Stilo 1 04-02-2005 03:36
(T) horn not working kopite Bravo / Brava 1 22-07-2004 02:52
(S) Air Horn Upgrade Cusim Cinquecento / Seicento 2 13-03-2004 23:32