Register Login
iNETFX Domain Registration - COM/NET/ORG £6.50 a year!
Reply
 
Thread Tools
Old 13-02-2018   #1
Join Date: Jan 2018
Posts: 3
Thanks: 0
Trader Rating: 0
Uzbekistan 
1.4 i.e. stutters, shuts off and doesn't restart

Hi,
Following problem on an MK2 1.4 i.e. engine:
The engine starts from cold, when takes of in first gear but as soon as it gets to constant speed or decelerates, the engine stops responding and shuts off. On occasion it will restart itself and continue accelerating when the gas pedal is pumped.
Also when revved at (rough) idle, the engine stalls when the rpms fall.

Fuel filter, spark plugs, ignition coil pack and cables, hall sensor, possibly ECU have been changed. Switched lambda for fuel pump relay, no change.

Any ideas other than wiring fault or injection unit?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by Yieeah; 13-02-2018 at 12:38.
Yieeah is offline Reply With Quote Quote 
Old 13-02-2018   #2
Join Date: Jan 2011
Location: edinburgh
Posts: 33
Thanks: 1
Trader Rating: 0
United Kingdom 
Re: 1.4 i.e. stutters, shuts off and doesn't restart

not sure what the hall sensor is, but it sounds classically like a cam position sensor

the ECU cannot time the ignition without it, and shuts off the injectors and spark plugs
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

dante giacosa is offline Reply With Quote Quote 
Old 13-02-2018   #3
Join Date: Jan 2018
Posts: 3
Thanks: 0
Trader Rating: 0
Uzbekistan 
Re: 1.4 i.e. stutters, shuts off and doesn't restart

The engine doesn't have a cam sensor, but the crank sensor is a hall sensor.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Yieeah is offline Reply With Quote Quote 
Old 15-02-2018   #4
Join Date: Aug 2004
Location: Wirral
Posts: 1,700
Thanks: 75
Trader Rating: 0
bluejohn125 has donated!
United Kingdom 
Re: 1.4 i.e. stutters, shuts off and doesn't restart

The water temperature sensor (inlet manifold at the rear of the engine) is quite critical to these engines with simple ECU / EFI... you could change it or at least check the wiring is not damaged.

Also the Lambda sensor is important. An ECU diagnosis should give some clues regarding faults (but less than later ODB2 systems).
Likes Camo16 liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

bluejohn125 is offline Reply With Quote Quote 
Old 12-03-2018   #5
Join Date: Jan 2018
Posts: 3
Thanks: 0
Trader Rating: 0
Uzbekistan 
Re: 1.4 i.e. stutters, shuts off and doesn't restart

The heater of the lambda probe is broken, however it isn't the issue as it's now unplugged and the manual for the Monomotronic MA1.7 claims that the engine will run even with all sensors and actuators except for the ignition pack, rpm sensor and injector unplugged.

It doesn't stutter anymore either, it just turns off during driving. After cleaning every electrical connection and mass point I could find plus the inside of the ignition switch, it mostly turns off and on after shifting into third gear. If it won't turn on again, shifting into second gear will restart the engine most of the time. It does get worse the longer the car is driven to the point of not starting anymore at all. There are no cables anywhere near the shifting linkage.

The ECU error codes are lambda probe and rpm sensor short to ground, the former is unplugged, the latter new and I checked the cabling for shorts. The fuel pump is also new.

My guess is an intermittent and impossible to find contact.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by Yieeah; 12-03-2018 at 15:25.
Yieeah is offline Reply With Quote Quote 
Old 16-03-2018   #6
Join Date: Jun 2007
Location: Mountain retreat SE Spain
Posts: 380
Thanks: 3
Trader Rating: 0
Spain 
Re: 1.4 i.e. stutters, shuts off and doesn't restart

Have you considered scrapping everything electronic (apart from ignition) and fitting a carburettor?
A few guys in Argentina have done this over recent years and so far are happy with the end result.
__________________
Give me an electronics free car any day, apart from ignition.
SFB is offline Reply With Quote Quote 
Old 16-03-2018   #7
Join Date: Aug 2004
Location: Wirral
Posts: 1,700
Thanks: 75
Trader Rating: 0
bluejohn125 has donated!
United Kingdom 
Re: 1.4 i.e. stutters, shuts off and doesn't restart

Why unplug the lambda sensor? It is critical to the fuelling of the car with the simple Bosch system fitted. You should fit a new sensor if the diagnostics said that it was originally faulty. The RPM sensor I think is what is known as the crank(shaft) sensor.. if this is faulty then it's a fairly regular fault for many Fiat cars, not difficult or expensive to fix.

Lambda should work without a heater, just won't work so well when cold. However I'm not completely sure if the early i.e. Tipos had a heated lambda, I think 3-wire sensors had no heater but 4-wire ones do?

Anyway a generic lambda should work fine if you wire it into the standard connectors.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

bluejohn125 is offline Reply With Quote Quote 
Old 16-03-2018   #8
Join Date: Jun 2007
Location: Mountain retreat SE Spain
Posts: 380
Thanks: 3
Trader Rating: 0
Spain 
Re: 1.4 i.e. stutters, shuts off and doesn't restart

Electronics and the ancillaries that accompany them are bad enough in modern cars, but must become unbearable as ageing progresses.
__________________
Give me an electronics free car any day, apart from ignition.
SFB is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Croma stutters at around 200rpm Dazler22 Croma 27 09-04-2014 17:49
(T) car stutters at 1500rpm ray300 Fiorino (Mk3) 18 20-03-2014 00:32
(G) Punto randomly shuts off when driving, have to restart. OllyCz Punto (Mk2/2b) 4 03-02-2011 01:49
(T) Power steering stutters adju Stilo 4 16-02-2010 18:47
(T) Misfires/Stutters rylander Barchetta 20 11-07-2007 13:29