Register Login
Save up to 15% with Adrian Flux insurance!
Reply
 
Thread Tools
Old 1 Week Ago   #1
Join Date: Jan 2018
Posts: 2
Thanks: 0
Trader Rating: 0
Uzbekistan 
1.4 i.e. stutters, shuts off and doesn't restart

Hi,
Following problem on an MK2 1.4 i.e. engine:
The engine starts from cold, when takes of in first gear but as soon as it gets to constant speed or decelerates, the engine stops responding and shuts off. On occasion it will restart itself and continue accelerating when the gas pedal is pumped.
Also when revved at (rough) idle, the engine stalls when the rpms fall.

Fuel filter, spark plugs, ignition coil pack and cables, hall sensor, possibly ECU have been changed. Switched lambda for fuel pump relay, no change.

Any ideas other than wiring fault or injection unit?
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides


Last edited by Yieeah; 1 Week Ago at 13:38.
Yieeah is offline Reply With Quote Quote 
Old 1 Week Ago   #2
Join Date: Jan 2011
Location: edinburgh
Posts: 15
Thanks: 1
Trader Rating: 0
United Kingdom 
Re: 1.4 i.e. stutters, shuts off and doesn't restart

not sure what the hall sensor is, but it sounds classically like a cam position sensor

the ECU cannot time the ignition without it, and shuts off the injectors and spark plugs
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

dante giacosa is offline Reply With Quote Quote 
Old 1 Week Ago   #3
Join Date: Jan 2018
Posts: 2
Thanks: 0
Trader Rating: 0
Uzbekistan 
Re: 1.4 i.e. stutters, shuts off and doesn't restart

The engine doesn't have a cam sensor, but the crank sensor is a hall sensor.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Yieeah is offline Reply With Quote Quote 
Old 1 Week Ago   #4
Join Date: Aug 2004
Location: Wirral
Posts: 1,636
Thanks: 75
Trader Rating: 0
bluejohn125 has donated!
United Kingdom 
Re: 1.4 i.e. stutters, shuts off and doesn't restart

The water temperature sensor (inlet manifold at the rear of the engine) is quite critical to these engines with simple ECU / EFI... you could change it or at least check the wiring is not damaged.

Also the Lambda sensor is important. An ECU diagnosis should give some clues regarding faults (but less than later ODB2 systems).
Likes Camo16 liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

bluejohn125 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Croma stutters at around 200rpm Dazler22 Croma 27 09-04-2014 18:49
(T) car stutters at 1500rpm ray300 Fiorino (Mk3) 18 20-03-2014 01:32
(G) Punto randomly shuts off when driving, have to restart. OllyCz Punto (Mk2/2b) 4 03-02-2011 02:49
(T) Power steering stutters adju Stilo 4 16-02-2010 19:47
(T) Misfires/Stutters rylander Barchetta 20 11-07-2007 14:29