Register Login
Save up to 15% with Adrian Flux insurance!
Reply
 
Thread Tools
Old 30-12-2019   #1
Join Date: May 2019
Posts: 10
Thanks: 0
Trader Rating: 0
Czech Republic 
Bad CAT? Error P0420

Hello, i own TIPO 1.4 16V 95CV with 48 000 km on the clock.
Recently it CEL light up on the dashboard. Could it be caused by poor quality fuel? Car has no symptoms so far, no rough running, consumption is normal, no power loss. I'm kinda desperate. Thx
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Obo67 is offline Reply With Quote Quote 
Old 30-12-2019   #2
Join Date: Feb 2004
Location: Faringdon, Oxfordshire UK
Posts: 6,372
Thanks: 507
Trader Rating: 1
portland_bill has donated!
United Kingdom 
Re: Bad CAT? Error P0420

Firstly, it would have been more helpful to have explained what the code meant. Few people will have memorised any codes, so will have to look it up, or just not bother, so you restrict the help you may get. You've understood what it means, but chose to keep that a secret.

Moan over.

The code relates to the cat output not being as expected. The second sensor, there as a check, is not getting the results it expects.

Cats do not fail as often as people think, they are very reliable and will usually outlast the car. They are susceptible to damage, or contamination. Earlier units, fitted under the car can be damaged if struck, on raised objects, animals, etc., but with most being now at the manifold, that is unlikely, unless the car has sustained frontal accident damage, which damaged the cat, and the cat not changed. Contamination would usually be from excess oil burning. Unless any of these apply, the cat is probably ok.

That leaves the sensors.
Need a proper diagnostic program, like MultiECUscan (MES) to show the readings of both sensors. It is likely that either or both sensors are failing, which is a simpler, cheaper job. Meanwhile, check the wiring to both sensors for any damage or poor connections.
Likes varesecrazy liked this post
__________________
13 years motor trade, 16 years motor industry. 14 years Driving Instructor & 7 years Fleet Trainer
Panda Alessi
portland_bill is offline Reply With Quote Quote 
Old 30-12-2019   #3
Join Date: May 2019
Posts: 10
Thanks: 0
Trader Rating: 0
Czech Republic 
Re: Bad CAT? Error P0420

Thank you, will do that. Already ordered proper diagnostic cable for my car. I will write whole description next time, I promise
Likes varesecrazy liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Obo67 is offline Reply With Quote Quote 
Old 3 Weeks Ago   #4
Join Date: Jul 2010
Location: Stoke on Trent
Posts: 61
Thanks: 1
Trader Rating: 0
United Kingdom 
Re: Bad CAT? Error P0420

Had both lambda sensors replaced under warranty. Supposedly a bad batch from Denso.
Likes varesecrazy liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

mattfred is offline Reply With Quote Quote 
Old 2 Weeks Ago   #5
Join Date: May 2019
Posts: 10
Thanks: 0
Trader Rating: 0
Czech Republic 
Re: Bad CAT? Error P0420

I suppose it did help, right?
TIPO has Lamba probes made by DELPHI.

I took the car to the dealer in the mean time. They cleaned both lambdas and intake air temperature sensor, they also inspected the cat and put new spark plugs in. Catalytic converter looks clean so no problem here I think. Error reoccurred so I will visit dealer again and tell them they might try to change Lambdas instead of just cleaning them.
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Obo67 is offline Reply With Quote Quote 
Old 1 Week Ago   #6
Join Date: Jul 2010
Location: Stoke on Trent
Posts: 61
Thanks: 1
Trader Rating: 0
United Kingdom 
Re: Bad CAT? Error P0420

They tried one at first which didn't work then both which did. Dealer said they were a Denso part but they maybe wrong.Had no issues since 🙂
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

mattfred is offline Reply With Quote Quote 
Old 6 Days Ago   #7
Join Date: May 2019
Posts: 10
Thanks: 0
Trader Rating: 0
Czech Republic 
Re: Bad CAT? Error P0420

Quote Originally Posted by mattfred View Post
They tried one at first which didn't work then both which did. Dealer said they were a Denso part but they maybe wrong.Had no issues since 🙂
Thank you.
I have a similar story. They tried to clean everything at first and check the intake and exhaust for any leakage. Then they inspected cat from the inside (clean) and changed upstream lambda. Problem reoccurred so they were about to replace the cat itself. I raised an objection that they should have tried smog test, which the car actually passed with not issues and as a bonus, they found out that downstream has a little bit higher output that it should have. They are about to replace it this Monday. I hope it will finally solve this...it has been 2 weeks since I brought the car do dealers garage for repairs. Luckily all covered within warranty
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Obo67 is offline Reply With Quote Quote 
Old 6 Days Ago   #8
Join Date: Jul 2010
Location: Stoke on Trent
Posts: 61
Thanks: 1
Trader Rating: 0
United Kingdom 
Re: Bad CAT? Error P0420

Mine was in twice. Thought they'd cured it with one sensor but it happened again the day after exelerating out of a 30mph so second time lucky. I have read that it's always best to replace in pairs.
Likes Obo67 liked this post
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

mattfred is offline Reply With Quote Quote 
Old 5 Days Ago   #9
Join Date: May 2019
Posts: 10
Thanks: 0
Trader Rating: 0
Czech Republic 
Re: Bad CAT? Error P0420

Very similar story to mine. Hopefully it will end happy in the same way as yours...
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

Obo67 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Error code P0420 Rudolph Punto (Mk2/2b) 0 18-03-2017 18:37
(T) P0420 error, lambda graph inside Razon Stilo 1 27-08-2014 07:30
(T) Error P0420 and lambda readings fiatritmo Stilo 1 28-09-2013 15:40
(T) P0420 - time for a new cat? atom0007 Punto (Mk2/2b) 19 21-03-2013 16:10
De-cat Good or bad? stevie FIAT Boo Archives 6 12-08-2008 12:52