Register Login
The UK's No.1 Chrysler Owners Forum
Reply
 
Thread Tools
Old 05-04-2019   #1
Join Date: Apr 2019
Posts: 2
Thanks: 0
Trader Rating: 0
United Kingdom 
Stop/Start

Hi all, I've had my tipo 67 plate for about a month now. Took it back to the garage yesterday as the stop/start has never worked.
Was told the battery had a full recharge and everything reset and working. Just picked the car up and to my surprise it's still not working, had a good 45min drive to see what the battery indicator was showing. It has never been full to I think it says 18v when full, its always been on half etc.
Just wondering, if the garage said it has had a full charge would it of dropped in such a quick time. Waiting for a call back, but it will be Monday now.
I'm just curious if it's a faulty battery surely they would of picked that up.

Thanks
__________________
FIAT Forum Useful Links:
Donate to FF | Buy FF Merchandise | Classifieds | FF Insurance | How-to Guides

overki11 is offline Reply With Quote Quote 
Reply
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump
Similar Threads
Thread Thread Starter Forum Replies Last Post
(T) Start stop.... then wont start. ruby67 500 6 03-01-2019 23:52
(T) 2011 500c semi auto, electronic issues, hill start, esp, stop start transmission etc. chris red 500 9 18-04-2016 17:00
(T) Start&Stop in stop-and-go traffic Mondaugen 500 63 17-10-2011 08:07
(T) Start stop - How long does yours stop for? Ransoman Punto Evo 9 17-08-2011 12:52
(T) replacement start key with start/stop button D1Gi Panda 2 30-05-2011 14:54