Welcome to FIAT Forum v3!

Yes, let's call it v3 as back in 2012 we had v2 - and yes, it's been that long since any major update!

Everything is different now, but as same as I could do it so you don't all get lost :)

Some parts have been renamed, such as:

Downloads > Resources
Events > Calendar
Gallery > Media

But rest assured it's just a name change, ALL the data has been imported (I made sure of that and my goodness I never want to do that again!)

There are lots of new things to explore, to be honest I haven't found everything yet so do have a play and let me know if you find any issues or anything missing so I can get right on it.

One of the big ones is that browser push notifications are now supported, so if you're browsing on a mobile you can allow the forum to send you updates - no need for emails each time :)

Current Issues/Tasks:
Search is rubbish, I need to get ElasticSearch installed on the server to solve that.
Gallery images have all been moved, so old links are broken. Working on a redirect script as we speak.
Classifieds need prefixes for existing ads, again, needs an import script so I'm on the case.
Members motors needs converting to the new format, it's useable now so don't worry about that - but it will change in the next week or so.

Links to guides and downloads at top of relevant forum
Thanks reaction missing
Remove number from forum urls
Make stickies more obvious
Show details under avatar on postbits
Login using SSO (Facebook, Microsoft, Twitter)



But please do let me know what you think and if there's anything else I can do!

Cheers!

Ben
 
Last edited:

h2ypr

500 + 600
Joined
Dec 2, 2005
Messages
2,002
Location
Halfway
Congrats on the update - I tried to use the app and it said I had to login so knew something was afoot.

Couldn’t get logged in so I’ve done a reset password and now logged in but my username/account is showing as imported_h2ypr - @ben is that normal?

Thanks for all your help in keeping this place alive.
Yeah I’ve worked it out.

So long and short of it, it’s to do with my email address. You can delete ‘imported _h2ypr’ as that shouldn’t exist - once you do I’ll update the email address on my actual account and that should prevent that happening.
 
OP
OP
ben

ben

The Boss
Staff member
Joined
Mar 16, 2002
Messages
18,515
Location
Taipei
Well that hit me in the face. Bit of a shock, not really in a good way.
So it looks 'fresher', meaning it has a brighter background, but why is this necessary, or 'better'?

Hey mate, sorry about that, but the upgrade was a necessity. From a design standpoint, maybe not as important - but technical standpoint most definitely. The old software was over 13 years old and running on a deprecated version of PHP. Whilst this didn't mean there were definitely security issues (although possible) - it did mean that the coding standards were stuck in the 2010's and nothing new was being created.

As an example, I had to build on any extra functionality that was requried, which amounted to over 100 extra modules! The new software can achieve pretty much everything with only 12! All that old code was also slowing things down and not ideal.

Also - the (old) design was built using tables, not divs. Again, for a designer and knowing from the technical standpoint = this is terrible! It means a lot of extra markup, which slows the site down buy requiring more to download, as well as a much slower rendering time.

I understand that for most people, this won't mean much = they just want things to "work", but there really is more in play here than just making things brighter :)

Thanks' button has disappeared. The answer about options behind the Like button does not answer this.

You can now tap like and it will just do a quick like, or you can hover over it (desktop) or hold your finger on it (mobile) to get a list of other reactions. I am using the "Love" reaction as thanks, but I guess that's not a total 1:1. I'll see if I can find something better - perhaps a hand doing an "ok" sign? But again, this shows the versatility of the new system - a new reaction can just be added, the old system was restricted to just like, dislike and thanks.

Under my avatar, is "I paid, change me". What is that? What am I supposed to change? I was happy with whatever was there before.

@Wiltshire Chris has written a great post showing this above mine, thanks Chris. It's strange that a few people have mentioned this, but actually nothing changed in that respect. That link was always there under your profile as your had donated...

The details that appeared under an avatar are now hidden until hovered over, so we now have to move the mouse to see someone's location. Why have these details become hidden?

Which details? The join date, post count and location? I'm sure I can get that added back again. When I started to conver the stock template, there must be loads of things I missed. My main concern before going live was just to make it look like the original forum style (colors and what not) - there are a billion options to setup, but don't worry, I'll get through them all!

Edit: Those are added now.

Someone needs to explain 'push notifications'. Do we still get the automated emails? Is this different, instead, or an additional 'benefit'? Got one automated email earlier today, none since, but there does appear to be threads I've posted to with new posts. How do we reinstate the email notifications?

It looks like some people had them disabled, you can enable them again here > https://www.fiatforum.com/account/preferences.
But if you are using push notifications, you don't need emails - you will get a Windows notification alert (Desktop) or a standard mobile alert if on your phone = you dont need the browser open. I have heard this might have issues on iOS (Apple) so emails are available as a backup

When I click a link in an email, it brings me to the first post of a thread, not the next post since I was last here. So now I have to head to the last page, and work back to try to remember when I was last there?

This might be due to the "last post read" markers not importing across - so for the first time you open a thread now it will need to set a new one, but going forward this shouldn't be an issue.

Quoting another post just became difficult

This is one thing that just became super super easier once you get used to it. As you scroll through a thread, you can either click the "+ Quote" button at the top of each post, or select some text and select "+ Quote". You can repeat this for as many times as you want (even across multiple pages) - then when you're done and get to the bottom, hit the "Insert Quotes" button and choose which ones you want to be put into the reply box.

The old site could do this, but it was super clunky and didn't work across pages.

Writing this post has also reminded me of one great editing feature, auto save! When you are writing a post, you can now navigate to other sections and when you come back, your text will still be there - no more lost posts!

I'm at a coffee shop now, but when I get home I will update the first post of this thread with outstanding issues, so you can be rest assured if it's on that list, I will get around to sorting it out :)
 
Last edited:
OP
OP
ben

ben

The Boss
Staff member
Joined
Mar 16, 2002
Messages
18,515
Location
Taipei
Yeah I’ve worked it out.

So long and short of it, it’s to do with my email address. You can delete ‘imported _h2ypr’ as that shouldn’t exist - once you do I’ll update the email address on my actual account and that should prevent that happening.

Merged the accounts now - you should be ok changing any details now (y)
 
OP
OP
ben

ben

The Boss
Staff member
Joined
Mar 16, 2002
Messages
18,515
Location
Taipei
Thanks Ben

Is the app unsupported now? Still not letting me login (unless I’m doing something wrong)
Yeah sorry, it required a load more payments which I didn't wanna make right now.

I'd like to see how popular just using the mobile style is for now, then can look at a dedicated app again in the future 😊
 
OP
OP
ben

ben

The Boss
Staff member
Joined
Mar 16, 2002
Messages
18,515
Location
Taipei
'Thanks' button has disappeared.

Thanks button returns 🤝

1637920044674.png
 

Wiltshire Chris

‍‍Accidental Barchetta owner
Joined
Jul 14, 2020
Messages
132
Location
Wiltshire
You don't even need to upload them each time now, you can paste an image into the editor and it will automatically upload it as an attachment! Really useful when using the screen snipping too
It's great isn't it? So much quicker to post snippets of manuals or whatever, it's going to be a great time saver for me.
 

Wiltshire Chris

‍‍Accidental Barchetta owner
Joined
Jul 14, 2020
Messages
132
Location
Wiltshire
Minor niggle or user issue?
If you want to create a new resource then you can upload a variety of file types (PDF, ZIP, PNG etc) but if you want to go back and change the files then the upload only seems to allow graphical files (png, jpg etc). Happy to find out I'm doing something wrong
 
OP
OP
ben

ben

The Boss
Staff member
Joined
Mar 16, 2002
Messages
18,515
Location
Taipei
Minor niggle or user issue?
If you want to create a new resource then you can upload a variety of file types (PDF, ZIP, PNG etc) but if you want to go back and change the files then the upload only seems to allow graphical files (png, jpg etc). Happy to find out I'm doing something wrong
Ok so this confused me too and I had to read the manual :LOL:

When you edit a resource, that "Attachments" button at the bottom is to add attachments to the description - that's why there are only image extensions allowed.

If you want to add new files, you need to click "Post an Update" then "Release a New Version".

I think though this will mean you need to upload all the files again. There must be a way to edit the current version, but I cannot find it - I'll need to contact the coder of the resource manager to find out if it exists!
 
Last edited:

theoneandonly

Member
Joined
Nov 18, 2020
Messages
79
Location
Northamptonshire
Obviously shedloads of work so far, so well done and thanks.
A tiny observation not of great importance but one of the minor things youll eventually mop up
On on a thread i noticed
Thanks for the help ��

Previously showed members names.
 
  • Like
Reactions: ben
OP
OP
ben

ben

The Boss
Staff member
Joined
Mar 16, 2002
Messages
18,515
Location
Taipei
Obviously shedloads of work so far, so well done and thanks.
A tiny observation not of great importance but one of the minor things youll eventually mop up
On on a thread i noticed
Thanks for the help ��

Previously showed members names.

Could you link me to an example? It looks like the import mashed something up!
 
OP
OP
ben

ben

The Boss
Staff member
Joined
Mar 16, 2002
Messages
18,515
Location
Taipei
One thing I just found, you can just press CTRL+Enter to submit a post - no need to click the "Post Reply" button :)
 

StevenRB45

Upstanding Member for Newcastle
Joined
Mar 23, 2007
Messages
9,350
Location
Newcastle
Looks fancy, though any hope of fixing broken links to gallery pictures.

There's going to be a lot of bereft members motors threads.
 
Top