Technical Weird blower fan problem

Currently reading:
Technical Weird blower fan problem

Cliffy1971

New member
Joined
Oct 22, 2022
Messages
3
Location
Redcar
Hi all , first of all I had to re- register, because my email was not recognised, I’m not a newbe, Iv posted lots of times .
My problem: my blower fans don’t work on a morning ( I’m guessing because it’s cold ) but they always work as normal on the way home at 4.30 , am I missing something here , is there a sensor that brings them on ? Or is it just coincidence? Before I start taking out the fan your thoughts on this would be appreciated.
On a morning nothing I do makes them work including the de-mist function, but on an afternoon they work fine . 2004 stilo abarth , a.c, digital climate control, manual.
 
Joined
Apr 27, 2011
Messages
31,706
Location
Near the M4
Hi :)

If it was manual.. I would blame a poor connection

But the AC : Climate uses electronics... so it could be that

Any chance of just powering the fan..?

Or is the whole Heater control..and flaps.. all shut down.??
 
OP
OP
C

Cliffy1971

New member
Joined
Oct 22, 2022
Messages
3
Location
Redcar
Hi just drove 30 miles ,fans worked perfect , as for the flaps , they work fine , every direction works fine
 

Muppet1

Springer Mad!!
Joined
Feb 8, 2008
Messages
1,053
Location
Somerset
Mine have been acting all Italian for a few months and have now stopped working full stop. Am debating on my next move for this, Control panel first or is there a resister somewhere to change first?
 

Muppet1

Springer Mad!!
Joined
Feb 8, 2008
Messages
1,053
Location
Somerset
So does anybody know if and where the fan resister is and the part number, please??
 

Davren

Moderator
Staff member
Joined
Jul 6, 2008
Messages
16,082
Location
London, UK.

Attachments

  • Heater Resistor.JPG
    Heater Resistor.JPG
    114.1 KB · Views: 12

Ralf S.

Well-known member
Joined
Dec 3, 2003
Messages
4,159
Location
The land that time forgot
X is notorious for temperature sensor (in the mirror) failure.. I would look there (or at least the external temperature that is displayed on the console).


Ralf S.
 

Muppet1

Springer Mad!!
Joined
Feb 8, 2008
Messages
1,053
Location
Somerset
Strangely enough, that's behaving itself more at the moment But used to chuckle to myself when It pinged up to -47.5 when it was 20+. Thanks, Davren its got the climate control.
Is it likely to be the resister or the fan motor bearing in mind I have no fan whatsoever?
 

Davren

Moderator
Staff member
Joined
Jul 6, 2008
Messages
16,082
Location
London, UK.
Thanks, Davren its got the climate control.
Is it likely to be the resister or the fan motor bearing in mind I have no fan whatsoever?
I don't think the climate control version has a resistor. According to ePER , it appears to have an electronic control unit. Item 8.
 

Attachments

  • Electronic Control.JPG
    Electronic Control.JPG
    99.1 KB · Views: 10

Muppet1

Springer Mad!!
Joined
Feb 8, 2008
Messages
1,053
Location
Somerset
So I managed to bag 71736005 electronic control unit on eBay friday morning which was a great find and for £49. Just waiting for it to turn up now and find out what a pain it will to fit it.
I am guessing its the drivers side of the heater unit up under the dash somewhere.
 
Top