Technical Variator

Currently reading:
Technical Variator

The first thing I did was replace the oil and filter which made no difference at all, I did think about sourcing an oil pump so that when I get stuck into it I have one to hand, it could be a blocked oilway or something but I'm thinking that if the pressure was that low when revving I would have other issues or have seen the oil light at tickover by now but it's given me a quick and easy idea to put an airline down the oil passage under the solenoid
 
The first thing I did was replace the oil and filter which made no difference at all, I did think about sourcing an oil pump so that when I get stuck into it I have one to hand, it could be a blocked oilway or something but I'm thinking that if the pressure was that low when revving I would have other issues or have seen the oil light at tickover by now but it's given me a quick and easy idea to put an airline down the oil passage under the solenoid
Same here no oil light or other (identified) sound indication of general faltering oil pressure.
The oil channels leading to the variator via the actuator seem long and narrow. One could imagine that over time oil crud could build up in these and finally hinder and/or reduce oil pressure enough to affect the variators movement from 0 to 1.
 
Variator actuator visit:
I just pulled my variator actuator or Phase transformer electro-magnet (Service Manual. Engine. Fuel System 10. Page 31). All in all it seem to be in ok(?) shape. No obvious oil crud buildup. It has been removed in the past as there is some liquid gasket remnants (to be cleaned off and replaced).

The Phase transformer valve:
shows some wear (see pic), but my untrained eyes don't see issues with it.
it fits fairly snugly and moves easily.

The Valve opposing spring is 20mm in length (relaxed) and has no problem moving the valve.

The Phase transformer electro-magnet:
shows 11 ohms both at the soldering points on top and at the electrical leads
connecting it to the battery sends its pin/piston(?) out 5mm
 

Attachments

  • I barchetta variator actuator pin.jpeg
    I barchetta variator actuator pin.jpeg
    73.2 KB · Views: 29
  • I barchetta variator actuator.jpeg
    I barchetta variator actuator.jpeg
    48.7 KB · Views: 23
  • Screenshot 2024-02-05 at 14.47.05.png
    Screenshot 2024-02-05 at 14.47.05.png
    77.6 KB · Views: 27
I tought same, that perhaps previous owner did variator overhaul. I did open old variator and it looked that it have newer opened. Also, if you look repair kits, there should be nylon (assume it is nylon) washer. My variator didn't have it. Only spring...
Were there any parts numbers on your new and/or old variator? I'm starting to wonder if the old ones w part # 55202772 lacked the washer (and space for it) and 60815644 (and later #) has it?
 
Were there any parts numbers on your new and/or old variator? I'm starting to wonder if the old ones w part # 55202772 lacked the washer (and space for it) and 60815644 (and later #) has it?

Sadly no. I would also like to do little investigation is there any differences. But all markings what there was, can be seen from photo i attached. But old one is hammered and darkened by oil, looks like it might be original. And as my B is from 96, it is high possibility that it is old part number. But can't be sure.

New part had number when i ordered it. And just checked that I paid under 400 euros + shipping. And probably it was last one, as now price is 560 euros in same place. These prices are getting out of hand... (put some bad language in here)

I had also couple grooves in variator bearing. You could hardly feel them with nails. But as everything we already apar, I did replace those bearing halves too. Just to be sure.
 
  • Like
Reactions: tjr
The first thing I did was replace the oil and filter which made no difference at all, I did think about sourcing an oil pump so that when I get stuck into it I have one to hand, it could be a blocked oilway or something but I'm thinking that if the pressure was that low when revving I would have other issues or have seen the oil light at tickover by now but it's given me a quick and easy idea to put an airline down the oil passage under the solenoid
I don't know how far you've gotten @Nodnolmick, but I have a short update from the b-95:

I have started the disassembly, The Cam belt seemed awfully loose, I will confirm. You may want to check.

Looking through the recorded service history of the b-95, it has received an oil change every 19.500km (average) as compared to the recommended every 15.000km or later 10.000km.

I will proceed to open up the variator to try and blow air through the oil ducts to and from the variator, but there was a lot less visible crud than expected. The cam looks in decent shape (ie not horrid), thus at the moment I doubt valve clatter as the source. If all goes well I'll try to open and clean the hydraulic tappets as well.
 
I will proceed to open up the variator to try and blow air through the oil ducts to and from the variator, but there was a lot less visible crud than expected. The cam looks in decent shape (ie not horrid), thus at the moment I doubt valve clatter as the source. If all goes well I'll try to open and clean the hydraulic tappets as well.
Nothing special crud- or otherwise in neither the variator nor in the oil ducts. I blew compressed air through all available ducts and some solvent in duct D (see service manual).

I suspect the variator is a newer version as there was both the spring and the plastic/teflon/nylon washer. It seemed to be in great shape. It shouldn’t be relevant, but the spring seemed to have shortened (down to 56mm on one “side” and 57,5mm on the other). I pulled it out to 59mm.

I opened and cleaned the tappets on the inlet side, but nothing horrendous there either. I’m thinking of doing them on the exhaust side also, but haven’t decided.
 
This is getting stranger if it's not the variator, when I get around to mine I'll just try swapping it for a different one
 
Update:
I ended up cleaning the tappets on the exhaust side as well. Being cheap and in the name of science I put everything back (same variator, same spring, same washer). I did an oil and filter change, but that made no difference for you @Nodnolmick afaik.
I can confirm that the cam-tensioner on the b-95 was not under tension and the cam belt was thus too loose.
I reset the timing using after market cam blocks and the upper timing marks on the fly-wheel.
The cam-tensioner was tightened as per instructions and the cam belt is no longer floppy.
Three (>40°C & rpm >3000) runs with the variator actuator connected has resulted in no horrid (engine falling out :eek: :eek: :eek:) noise.

With the reset timing, idle is now good, it's no longer hunting and threatening to stall at traffic lights etc.

I'd be very interested in hearing your conclusion/experiences @Nodnolmick. Until then/further I'm writing off the b-95 mid-rpm-range, variator-active, rattle; as a loose cam belt/tensioner (probably in conjunction with jumped teeth/bad timing (hunting idle)) issue.
 
Summer is coming, still no MOT or tax so I can't continue using it as is so thanks for the tip I will be looking at the cam belt tensioner when I take it apart in the coming weeks and will let you know what I find
 
  • Like
Reactions: tjr
Summer is coming, still no MOT or tax so I can't continue using it as is so thanks for the tip I will be looking at the cam belt tensioner when I take it apart in the coming weeks and will let you know what I find
Still don't understand how disconnecting the variator actuator/solenoid stopped the rattle from occurring though... The loose cam belt would still be loose.
 
My only thought is the variator not being able to hold in the advanced position with a loose belt allowing it to chatter but it does sound like you avoided a potential catastrophy, maybe we shouldn't have continued using them with the variator solenoid disconnected
 
My only thought is the variator not being able to hold in the advanced position with a loose belt allowing it to chatter but it does sound like you avoided a potential catastrophy, maybe we shouldn't have continued using them with the variator solenoid disconnected
To the contrary I think it was an excellent move to disconnect the variator 🤝

In the best of worlds I would have caught the hunting idle, understood that the timing might be off, and fixed it the same day(!). The worst would have been to leave all as is including letting the horrendous rattle continue, I suspect it would have led to engine failure. With that sound, something was taking a tough beating..!
 
Back
Top