Technical Tapping noise 1.9D DOBLO I fixed it!

Currently reading:
Technical Tapping noise 1.9D DOBLO I fixed it!

xs1100e

New member
Joined
Sep 30, 2007
Messages
34
Doblo 1.9D

Hi my Fiat Doblo 1.9D on a 51 plate as started to make a tapping noise from the engine its done 78,000 miles with no problems the noise is there all the time at any revs and stays the same hot or cold any ideas would be most helpful I have removed the cam cover and checked the spray bar seems to be getting oil up to cam and valve gear the van has had an easy life with regular oil changes. I have not yet replaced the cam belt or tensioner and it did have a coolant leak from some where around the timing cover but as a get me home fix rad weld was used and the coolant level as stayed constant so I left it alone.it sounds like a rough 899cc cinquecento with wornout hydrolic tappets,could it be that the shims need adjusting and are the shims the same as the old 132,128,x19ect?? regards xs1100e
 

Ozzie1989

Doblo Moderator
Joined
Jan 26, 2006
Messages
2,127
Location
South Wales
Re: Doblo 1.9D

I would probably recommend getting the belt and tensioner replaced anyway because it's probably going to fail sooner rather than later (n)

A similar thread that was posted not so long ago started out as a tapping sound and ended up needing a new head after the cam broke. Could be that your belt is on it's way and causing problems. How does it run when at idle, if it's rough then I'd suspect your belt could have slipped a tooth.

If not then I'm stuck for ideas at the moment, but I'm sure someone else might have some (y)
 
OP
OP
X

xs1100e

New member
Joined
Sep 30, 2007
Messages
34
Re: Doblo 1.9D Tapping noise from engine

It runs and sounds sweet but as soon as the revs increase above engine idle the tapping starts I thought may be the water pump may need replacing,and yes the timing belt will be replaced as soon as this is sorted out kind regards and thanks for the fast reply.
 
OP
OP
X

xs1100e

New member
Joined
Sep 30, 2007
Messages
34
My Doblo van 1.9D CARGO 52 plate as been making a tapping noise for a few weeks now, no loss of power just an annoying tappet type sound after a few weeks of careful observation I pin pointed the noise to the alternator belt tensioner which I bought and fitted £30.00 and 20 minutes later I ran the engine and its quite as a mouse!
Cam belt to do next bet there a pig to do any tips?
 
Top