General Smell + smoke from heater..!! New 100hp..

Currently reading:
General Smell + smoke from heater..!! New 100hp..

medlow

New member
Joined
Jun 30, 2007
Messages
131
Location
Northants & Cambs
Picked up my brand spanking new Electroclash Grey 100hp today.. Great fun and a great colour, although running it in so can't be to heavy footed..

Upon turning the heaters on we noticed the cabin filling up with hot plastic smelling smoke, not thick smog, just a misty type smoke . We promptly turned it off and opened the windows.

On further use the heater now does not smell nearly as much and no smoke appears.

Is this normal.???? Was the heater matrix just running in?

All seems fine now, just a very faint smell left (that seems to be going on more use) and no smoke at all.

I think I may phone the dealer on monday..

Also, the same old question.... How long are you guys running the 100hp in for??? Only after 1 day I am sooo tempted to drive it like I want..

Thanks!!

MED.
 

santa

flying low...
Joined
Mar 18, 2005
Messages
843
Location
Viborg, Jylland
The smell and smoke didn't happen with my 100HP, so I would call the dealer monday just to be sure.

With regard to running it in I didn't do anything special when I got my 100HP.
The most important thing to remember is getting the engine up to running temp. (oil and water) before flooring it.
Within the first few hundred km I had already hit the rev. limiter (and yes it's at 7.000 rpm) and after 18.000 km it still doesn't use any oil and it drives like a dream.
No doubt others will tell you to run it in like in the old days, but since Fiat doesn't mention it in the manual (at least I didn't notice it in the manual) they obviously don't think it's that important.
 

Toomanytoys

Member
Joined
Jun 18, 2007
Messages
150
Location
Lincolnshire
Just be sensible about it... as said, let it warm up and dont use full throttle for a few hundred.. dont drive it too slowly either... build the revs up over the first 6-700..
 

MHRAR

Member 134
Joined
Aug 20, 2007
Messages
157
Location
Berkshire
Running in guidance from Honest John.....

Just a personal note - I feel that it is just as important not to labour the engine and transmission by changing gear too early!
 

Attachments

  • Running ina petrol engine.doc
    27 KB · Views: 13
Last edited:

Andy Panda

New member
Joined
Feb 24, 2006
Messages
374
Location
London
Smell seems to be normal as quite a few have reported it,i've yet to put the heater on and i've had since April:) I always have the air-con going though.I didn't run mine in at all,the dealer said it was unnecessary and a mechanic even said it could have a negative effect saying that the engine would never reach it's full potential otherwise.
 
OP
OP
M

medlow

New member
Joined
Jun 30, 2007
Messages
131
Location
Northants & Cambs
Well it is going back to FIAT on weds to sort:

Paint blemish, gouge on rear bumber (spotted luckily when picking it up) :mad:
I have no locking wheel nut key :mad:
Or key code card :mad:
Or service book :mad:
Roof bars to be fitted :)
And to investigate the smoke and smell (just in case):confused:

Some pics, the usual but worth posting for anyone that cant decide on colour... the grey is supurb!!!(y) (the photos do not do it justice!)

IMG_0559.JPG

IMG_0557.JPG

Cheers for the help chaps!

MED.
 

drrawle

New member
Joined
May 12, 2007
Messages
34
Location
Oxfordshire
Smoke and Smell are just the heater matrix where they got body seal on it. I have seen three do it now so don't worry :)
 
Joined
Aug 4, 2004
Messages
16,617
Location
Watford
fiat uk hold the key code card.....i think one of the owners a while back embarked on an odyssey to get it sent to him....never heard from again......
 

usher

New member
Joined
Jul 24, 2007
Messages
111
fiat uk hold the key code card.....i think one of the owners a while back embarked on an odyssey to get it sent to him....never heard from again......


tried to get my immobiliser code , when my letter arrived from the ISR I sent them an email asking how to obtain my code. They replied straight away & said its accasible by Fiat UK & the AA have direct access also, I said I would prefer to also have it & they replied again that for security reasons its not available.(n)
 

rambyuk

New member
Joined
May 14, 2006
Messages
278
Location
Dorset
tried to get my immobiliser code , when my letter arrived from the ISR I sent them an email asking how to obtain my code. They replied straight away & said its accasible by Fiat UK & the AA have direct access also, I said I would prefer to also have it & they replied again that for security reasons its not available.(n)

Yeah, them not sending it is normal, I think it's insurance forcing that in the UK.
 

Henne100HP

New member
Joined
Mar 25, 2007
Messages
74
Location
Amsterdam
About running in the car..
I didn't. Yes I warmed em up before the pedal went to the metal.
But if you don't you'll probably get a lazy car.

The clue is the same as you'll have a new and larger/tuned cilinder on a moped.:slayer:

Drive the car with a lot of differrent revs. And don't argue with your girl when you are going to the redline and hit some illigal speeds...:D
 
OP
OP
M

medlow

New member
Joined
Jun 30, 2007
Messages
131
Location
Northants & Cambs
Update:
It's back from the dealership now. Rear bumper looking like new again and I have a new set of looking wheels nuts.

You're correct, they do not hand over the key code card. They are all kept on a central DB.

The smell is normal apparently, but if I get the smoke again I will be taking it straight back.

My100hp has now done 350 miles at varying revs, although I took a mate out in it today and was touching 5krpm mostly but no more. The gearshift is getting better/smoother with each mile and the lurvly, throaty engine sound is getting nicer too. Anyone else noticed that the 100hp pops and splutters a bit while coming down the revs? :slayer:

It has developed a slight knocking from the rear suspension though. I will wait and see if it gets worse before moaning at the dealership again.

MED.
 

HP

I was only doing 80...
Joined
Mar 22, 2002
Messages
13,429
Location
North East
Mine did the smoke too, the first time the air con kicked in and whacked the fan up. Opened the windows for a min, it never did it again.
 

HPsimon

New member
Joined
Sep 19, 2007
Messages
19
Great choice......I've also just picked up a grey HP.

I have noticed a slight burning smell too, though I've had no smoke! Assumed it was just a new car thing and ignored it.

Interested in the comments regarding running in......I've now done 250 miles in mine and not taken it about 4,000rpm, but I think I'll start to increase that now (when the engine is warm of course). Not sure I'll be hitting the red-line quite yet though!!!

Simon
 

Andy Panda

New member
Joined
Feb 24, 2006
Messages
374
Location
London
It has developed a slight knocking from the rear suspension though

I'm getting a similar thing,not sure if it's suspension or if the rear bumper is knocking on something,doesn't happen that often so it's a bit difficult to pinpoint the cause
 

HP

I was only doing 80...
Joined
Mar 22, 2002
Messages
13,429
Location
North East
......Interested in the comments regarding running in......I've now done 250 miles in mine and not taken it about 4,000rpm, but I think I'll start to increase that now (when the engine is warm of course). Not sure I'll be hitting the red-line quite yet though!!!

Simon


I've read a few people's of advice on running in. Mine's up to 350 miles now and does feel like it's freeing up nicely. I've upped my own limit to 5,000 revs, but still haven't used more than half throttle.

Sport button went on at 150 miles, and stayed on!
 
Top