General Scudo Panorama no longer starts (engine turns over on starter)

Currently reading:
General Scudo Panorama no longer starts (engine turns over on starter)

scudodead

New member
Joined
Jun 23, 2022
Messages
4
Location
cumbria
Hi, I have a 2007 Fiat Scudo Panorama 2 Litre diesel 120 M-JET SWB MPV. Brilliant car version of the van!
The Scudo has been well maintained and serviced (inc cam belt) but nothing done to it since before the pandemic....have only done approx 80000 miles from new with a major engine rebuild about 5 years ago.
Went to use it yesterday and it started but then almost immediately stalled.
Now it will not start at all. The engine turns over on the starter as normal but will not start.

Problem i have is it is stuck on the drive and I live rural, so the nearest garage is miles away. Plus they cannot fit it in for 3 weeks!

Have searched this forum but am unsure as to what is wrong. The battery is fully charged and the starter motor works fine. I have tried both keys and neither will start it. I have checked the fuses and the ones to do with the fuel are OK.

This is what happens when i try to start my Scudo.
Key turns and all the relevant dashboard lights come on OK.
There is a slight whirring noise in the engine compartment but no noticeable click.
A few seconds later some of the lights (including the glow plug warming one) go out OK.
Turning the key further engages the starter motor strongly but the engine fails to start.

Does anyone have any ideas?

Thanks for any replies...
 
Joined
Apr 27, 2011
Messages
30,266
Location
Near the M4
Hi :)
If it was running and then stopped running

Its likely to be a fundamental thing..

Fuel supply
Sucked in something to upset air supply

Something broken ...

When was it last driven for more than 20 minutes?
 
OP
OP
S

scudodead

New member
Joined
Jun 23, 2022
Messages
4
Location
cumbria
Hi :)
If it was running and then stopped running

Its likely to be a fundamental thing..

Fuel supply
Sucked in something to upset air supply

Something broken ...

When was it last driven for more than 20 minutes?
Last used a couple of days before.

Have checked the starting and cannot hear any click as mentioned in other posts. So, i assume the fuel side is not working. Still working through the forum posts but guess it is beyond an easy home fix.....unless someone knows better....

Also, anyone know of a mobile mechanic in the South Cumbria area?

Or any suggestions on how to get a car to a garage as our breakdown cover doesn't cover recovery for a home breakdown....
 
Joined
Apr 27, 2011
Messages
30,266
Location
Near the M4
Hi again :)


Biggest concern is a Timing belt problem..

Can you rule that out ?


Can you see valves through the oil filler??

If the engine turns on the starter.. but the valves dont move.. thats serious
 
OP
OP
S

scudodead

New member
Joined
Jun 23, 2022
Messages
4
Location
cumbria
If you broke down a couple of miles from home.. your recovery would be covered :)

Check your policy for the relevant distance
Cheers for your help.....just found the policy document and i think it does cover home assistance including transporting to the nearest repair garage (it is booked in to the local garage). Just need to phone them to double check....

Not sure where the oil filter is? Is there any other way of checking the the timing belt?

I had the belts done during the engine rebuild a few years ago, so fingers crossed its not that....
 
Top