Technical Scudo 2.0jtd power steering

Currently reading:
Technical Scudo 2.0jtd power steering

martin1962

New member
Joined
Aug 14, 2010
Messages
25
Hi all

just took my 2001 van for its MOT and it failed on the power steering as he says its to stiff when the car is satationary but fine the moving now i have notice this ever since i bought the van from new.
has anyone found the same problem and would changing the fluid help or is it going to be a new pump.Any advice would help
 
OP
OP
M

martin1962

New member
Joined
Aug 14, 2010
Messages
25
Hi
No i mean with the van in idle.
Ok just got a new pump and fitted it the next question is how do you bleed the system i have tried rapidly turning the steering through its entirity in both direction but with no bubbles or use of decrease in fluid and there must be air in the system as the new pump just and a small amount of fluid in it that i primmed it with.
 

dmcchris

New member
Joined
Jan 17, 2013
Messages
14
Location
llanelli
to bleed all you should have to do is turn the wheel to full lock a couple of times slowly, thats what i have done on other vans,let me knoe if the pump fixed your problem as mine is the same
 
OP
OP
M

martin1962

New member
Joined
Aug 14, 2010
Messages
25
Hi dmcchris
Yes the pump did the job but when i first star the van in the morning the steering is stiff but if i re it i hear a clink and the steering is then free as should be and works fine untill it has stood for about 12 hours then the same again this is why i wondered if there was air in the system and i have bleed it as you have suggested. Another thing i noticed is the belt keeps coming of by two vaines wide . Now nothing has altered in the alignment other than a new pump and the pump part number is the same as my old one
 

bigdong

New member
Joined
Jan 28, 2009
Messages
464
Another thing i noticed is the belt keeps coming of by two vaines wide . Now nothing has altered in the alignment other than a new pump and the pump part number is the same as my old one
I remember having the same problem, seems to be quite common in these vans. Even the dealer spent 2 days trying to work out why and failed. What I used to do was replace the belt on every service, for all the price of the belt and 5 mins to change. It will rip the belt if you leave it long enough.
 
OP
OP
M

martin1962

New member
Joined
Aug 14, 2010
Messages
25
Well i found out why whe belt was miss aligned from the outside edge of the pulley to the outside edge of the case is 5mm wider than the original . The pulley does not sit on the input shaft as far even though they are the same part number so that pump will go back.
 

r masters

New member
Joined
Apr 19, 2010
Messages
617
have u checked your wishbone and balljoints to see if there ok they might need greased up or replaced pump might be ok
 

narcisssssss

New member
Joined
May 26, 2017
Messages
2
Hi. I got a 2008 sh Scudo. It is working fine except power steering. Is a big chalenge to park the car in some places, I need an airport.... Driving is ok, the system work about 30% of capacity. There is no leak or noise. Please, if enyone experience this share details. Tomorow I have a workless day and I want to take out the pump and see closely. Could it be an electrical fault? Do I need a computer settings if I remove the pump? Is there a switch part for two working levels? Thanks.
 
Top