Technical rough unstable idle, boggy acceleration, O2-sensor light on, it was all TPS

Currently reading:
Technical rough unstable idle, boggy acceleration, O2-sensor light on, it was all TPS

havinfun

New member
Joined
Jan 21, 2022
Messages
13
Location
Inside
The previous owner had already replaced an number of parts and sensors and still the idle was very unstable. It would never pass inspection, so I got the car for cheap and liked it too much to see it go to the scrapyard.

First I hooked up a voltmeter to the O2-sensor and was surprised to read 0.04 volts (far to lean) but a good explanation for the rough idle, the slow acceleration and the O2-sensor light coming on.
Then I provoked a rich mix and the sensor gave the expected voltage (over 0.8 volts). Provoking a lean mix stalled the already lean running engine immediately. So the O2-sensor worked fine and the light only came on because its readings were below the range (0.1 to 0.9 volts).

That made me look for air leaking into the system. I plugged up all vacuum lines and started the engine to see if it was running better then. It wasn't.
Then I blew the steam from a vapor cigarette into one of the lines. Nothing! I tried it again for several minutes. No steam leaking out means no air leaking in.

Next I disconnected the sensors one by one with the engine running. It ran better with the throttle position sensor (TPS) off. I marked its current position, took it out and it looked good, just the normal superficial scratch marks (I still got a new one as it was just 16€). I looked for data on how to adjust the sensor correctly found one for a Peugeot with the same Bosch mono jetronic but it didn't help (a different position to before but still the same 0.04 volts).

At last I did it how we adjusted the idle mix on old carburators (as we didn't have CO-meters): I put the TPS back in, disconnected the idle regulator, hooked up an external tachometer and adjusted the TPS until the engine was running with the best idle (smoothly running with the highest rpm). It improved from rough jumps between 600 and 900rpm (in the previous position) to a stable 1050rpm. I connected the idle regulator again and waited for the ECU to correct the idle to around 850rpm.

The last step was to reset the ECU according to the owners manual.

Maybe this helps everybody struggling with those symptoms as the fix came as a surprise to me. It's possible that the unexpected readings coming from the TPS confused the ECU.
 
Top