Repairing Headlights

I hope pictures tell you more that my words :)

Before you decide to remove the stalk unit,

  • Rule out all the other possibilities which are mentioned in the Fiat Forum.
  • Make sure that there are no problems with the 3 wire connectors. Check the connectors if they are firmly in place. If the bigger one (on the left) is loose or faulty, headlights & fan & wipers won't work.

01.JPG

Opening up the stalk unit was a bit difficult. Even when the 4 screws were removed, the box was still firmly intact. I had to use several screw drivers so that the released locks didn't get locked again. Eventually the box was opened up.

IMPORTANT : Before removing anything, carefully examine the parts, their places and their initial positions.

02.JPG

This plastic case holds 3 metal pieces which act like switches as the lights stalk is operated.

03.JPG

In this my very case, one of the metal pieces had gotten stuck in its place so that it didn't close the circuit. Probably some bad surface connection caused heat (I guess!), eventualy ended up melting the case around the metal bridge.

04.JPG

The same stuation from a different angle. Compare the faulty one to the others.

05.JPG

Here some precise cutting procedure took place. Using my hobby knife I set the metal piece free and removed the deformations from the edges.

06.JPG

I also had to strecth the spring a bit so that it applied enough pressure to the metal bridge.

07.JPG

I reassembled the pieces and it was again ready for duty (at least for some time).

08.JPG

Putting all the parts back together was the most time taking of all.

ext1.JPG

This one has nothing to do with the main procedure. It shows the wipers stalk in case someone is interested in.

Apologies for the vocabulary and grammer mistakes. :eek:
 

mareaist

New member
Joined
Jul 22, 2009
Messages
9
Hello I am new to this site also. I have a marea 1.6 elx automatic transmission (2001). My problem is about front fog ligts. I couldnt find its fuse location at user manual. how can I find it? (when I press the button led is on but no lights) . Thanks.
 

Isbit

New member
Joined
Jul 20, 2011
Messages
6
"Make sure that there are no problems with the 3 wire connectors. Check the connectors if they are firmly in place. If the bigger one (on the left) is loose or faulty, headlights & fan & wipers won't work."
-----------------------------------------------------------------------------


where are 3 wire connectors that you are talking about?
I have problems with the wiper, headlight and fan not working and all fuses are intact. help please:confused:
 
Top