Technical Rattling Sky Window

Currently reading:
Technical Rattling Sky Window

nicolas2327

New member
Joined
Nov 4, 2005
Messages
2
Location
Nicosia
Hi to all Stilo owners and Happy New Year. This is my first thread and is intended to other Stilo owners with their cars fitted with the sky window. While driving, with the sky window in the 2nd opening position, I hear a loud noise coming from the roof. This noise disappears if other setting are selected. Did you faced the same problem and how did you solve it? I am not sure if this noise comes from partly loose glass parts or from the motor assembly.
 
Last edited:

ABZSTILO

Inverness Sierra
Joined
Dec 4, 2005
Messages
1,409
Location
Inverness
Sorry, mine seems fine and doesn't make any strange noises (yet!). However, I suspect that the surround trim inside will need some fixing later in the year - looks scruffy :rolleyes:
 

fueltank

New member
Joined
Jun 21, 2004
Messages
32
Location
bradford, United Kingdom.
had one for 11months before i got rid and it went back 11 times they never cured it. Thought it was a one off so me new one has skyroof, been back once, cured it for about 8 openings before it started again. goes back next week again. I asked them to see if its a design fault. Last time the packed everything in foam rubber but someting must be coming loose.
 

T14086

Forum Moderator
Joined
Sep 12, 2004
Messages
39,858
Location
Preston
fueltank said:
had one for 11months before i got rid and it went back 11 times they never cured it. Thought it was a one off so me new one has skyroof, been back once, cured it for about 8 openings before it started again. goes back next week again. I asked them to see if its a design fault. Last time the packed everything in foam rubber but someting must be coming loose.

Helps us if you say what it is (not?) doing?
 

Argonought

It's about GO! not SHOW!
Joined
Sep 8, 2005
Messages
7,593
Location
POOLE, Dorset
I think the original poster is simply confusing buffeting for a rattle.

Mine does the same on position 3 (one blade open) at between 50 - 65 mph.

It's fine at around town speeds and sounds pretty good at much higher speeds ;)
 

bozzy

Veracocha
Joined
Mar 1, 2004
Messages
3,706
Location
Birmingham, United Kingdo
Argonought said:
I think the original poster is simply confusing buffeting for a rattle.

Mine does the same on position 3 (one blade open) at between 50 - 65 mph.

It's fine at around town speeds and sounds pretty good at much higher speeds ;)

I tried your cotton bud trick and they came out green!!! Looking at the seal it looks perfectly black but the moss is setting in there somewhere, 04 car as well so very surprised.
 

Argonought

It's about GO! not SHOW!
Joined
Sep 8, 2005
Messages
7,593
Location
POOLE, Dorset
bozzy said:
I tried your cotton bud trick and they came out green!!! Looking at the seal it looks perfectly black but the moss is setting in there somewhere, 04 car as well so very surprised.
Yeah, I felt a lot better getting mine back to black on my 02 (y)

I'm hoping that AutoGlym stuff will keep the mould at bay.
 
Top