General Mk2b JTD Gearbox problem?

Currently reading:
General Mk2b JTD Gearbox problem?

a1ant

-~Moderator~-
Staff member
Joined
May 30, 2006
Messages
5,266
Location
UK
Hi, bit of advice needed please....

Mk2b 5 speed manual JTD.
The problem is that when you move the gearstick to the left (as if to go into 1st or second) and then let go, it does not return to the central neutral position. If you move it to the right (ie to go into 5th or reverse) and then let go it springs back like it should into central neutral position.
Anyone have any idea what this could be? Is there a return spring or something similar that may have gone??

Any advice much appreciated.

Thanks, Alan
 

toad101

just can't get enough
Joined
Apr 21, 2006
Messages
5,077
Location
south east wales
the gear linkage bushes are worn or sticking, had complete linkage replaced on mine, some people have just removed the linkage lubricated the bushes then refitted to the car
 
OP
OP
a1ant

a1ant

-~Moderator~-
Staff member
Joined
May 30, 2006
Messages
5,266
Location
UK
thanks for the reply.... the car has just done 20k miles, so hopefully they wont be worn yet. Wen you say lubricate them, is it just a case of popping them all off and putting some grease on the ball joints??

Thanks, Alan
 

toad101

just can't get enough
Joined
Apr 21, 2006
Messages
5,077
Location
south east wales
mine had only done about 16k the linkage was replaced as it was under warranty, its now on 33k and no problems.
theres a couple of threads on how to fix it do a search and you should find it
 
OP
OP
a1ant

a1ant

-~Moderator~-
Staff member
Joined
May 30, 2006
Messages
5,266
Location
UK
Lovely, cheers mate your a legend!
 

moe86

New member
Joined
Sep 1, 2007
Messages
65
Location
Cairo, Egypt
just bought a brand new mk2b 2 weeks ago & i wasn't happy with the gearbox when "reversing" ,cuz it's not "smooth" enough like other new cars i've driven before,i have to push it hard to the right & then hard backwards to get sure that it's on "R" .i don't know the exact problem tho!
DO anybody here have the same problem ?
It's a 2008 8v 1.2 5-doors.
 

oldernowiser

New member
Joined
Jun 21, 2007
Messages
73
have to push it hard to the right & then hard backwards to get sure that it's on "R" .i don't know the exact problem tho!

It's a 2008 8v 1.2 5-doors.
I have a 2005 2B 1.2 8V and reverse is no problem, provided you remember to lift the collar on the stick to release the inhibit...

Although it must be said that the whole feel of the 'box improves when the oil is warmed up.
 
Top