Technical Low speed juddering 2011 1.3-Diesel

Currently reading:
Technical Low speed juddering 2011 1.3-Diesel

Doulting

New member
Joined
Jan 23, 2018
Messages
12
Hi everyone! We have a new to us 1.3 diesel Trekking 70,000 miles which seems to have been neglected maintenance wise. Unbelievably dirty oil etc etc! All filters and oil have now been changed and the service reset with multiecuscan BUT! We still have a really annoying judder under low speed/load which disappears once it’s given some revs. No engine codes are present. Changing the filters hasn’t made a difference to this.
My initial thoughts are that the Maf might be at fault/dirty since the air filter was poor.
Multiecuscan gave the Maf a temperature reading of 30c early this morning with a cold engine, this doesn’t sound right does it? I’d expected it would be around 10c or outside temp.
I don’t want to rush out and buy a new part on a hunch especially when they cost so much!
I also wonder if a forced regen might not be a bad idea.

Any ideas folks!! Thanks in advance!
 
OP
OP
D

Doulting

New member
Joined
Jan 23, 2018
Messages
12
Worth checking the DogBone engine mount..
It will accentuate low RPM judder
Thanks for that suggestion, I’ll check to when underneath. The juddering is actually more like a misfire under initial acceleration which clears with more revs. I’m also wondering if the egr might be the culprit!?
 
Joined
Apr 27, 2011
Messages
30,267
Location
Near the M4
What age is this?

Layout changed through the 1248's life

My mj's are all early.. glowplugs at front..

Later stuff they are hard to access.. may have other common running issues

You sensor does seem to be reading strangely though.. worth investigating
 
OP
OP
D

Doulting

New member
Joined
Jan 23, 2018
Messages
12
What age is this?

Layout changed through the 1248's life

My mj's are all early.. glowplugs at front..

Later stuff they are hard to access.. may have other common running issues

You sensor does seem to be reading strangely though.. worth investigating
What age is this?

Layout changed through the 1248's life

My mj's are all early.. glowplugs at front..

Later stuff they are hard to access.. may have other common running issues

You sensor does seem to be reading strangely though.. worth investigating
Update! Well, after deep contemplation ;) I decided upon new maf sensor and when fitted all seems well for the time being! AND I didn’t forget to reset to a new sensor using multiecuescan.
The results are a way much smoother takeoff from idle and no juddering/misfire like symptoms . Also no sooty diesel stink from the exhaust, now all I’m getting is that odd metallic stench from the cat when the engines warmed.

Having looked an excellent Turkish YouTube video of cleaning the egr etc I would imagine that ours is maybe probably blocked in a similar way after bad maintenance, but that’s a job for the future, I’ll update any progress. For the time being all is well.
 
OP
OP
D

Doulting

New member
Joined
Jan 23, 2018
Messages
12
Update! Well, after deep contemplation ;) I decided upon new maf sensor and when fitted all seems well for the time being! AND I didn’t forget to reset to a new sensor using multiecuescan.
The results are a way much smoother takeoff from idle and no juddering/misfire like symptoms . Also no sooty diesel stink from the exhaust, now all I’m getting is that odd metallic stench from the cat when the engines warmed.

Having looked at an excellent Turkish YouTube video of cleaning the egr etc I would imagine that ours is maybe probably blocked in a similar way after bad maintenance, but that’s a job for the future, I’ll update any progress. For the time being all is well. I’ll also take a look at the map sensor when I get time, I’m hoping it’s easier to remove than the doblo one.
 
OP
OP
D

Doulting

New member
Joined
Jan 23, 2018
Messages
12
Well there’s nothing like spending a Friday evening messing with cars, especially when the inevitable and predictable black gunge appears!
New map fitted and tubes cleared out. Should help a bit hopefully! Not the best photo cos I mislaid my glasses somewhere during the experience.
1EDE57CC-2AF2-46C4-B99F-73DB0137A6C1.jpeg
 
Top