Technical Immobiliser Problems

Currently reading:
Technical Immobiliser Problems

StiloRuS

New member
Joined
Oct 22, 2007
Messages
4
Hi, ive bought a fiat stilo accident damage and repaired it, everything was working fine, i fitted an original visteon system in the car, i had to change the fuse for the system as it was blown, after i tried to start the car but the immobiliser sign on the dashboard was flashing, and the car wouldnt start. Ive had everyone come to check the car fromt he locksmith to diagnostic expert and he couldnt resolve the issue. If anyon can help please do.
 

Deckchair5

Whaddya mean too old?
Joined
May 1, 2005
Messages
5,607
Location
Roman city Bath
ive bought a fiat stilo accident damage and repaired it, everything was working fine
including the engine?

i fitted an original visteon system in the car, i had to change the fuse for the system
which fuse? Why did it go?

after i tried to start the car but the immobiliser sign on the dashboard was flashing, and the car wouldnt start
turning over but no sign of life?

Ive had everyone come to check the car fromt he locksmith to diagnostic expert and he couldnt resolve the issue
so what did they do and what did they check?
Checked the fuel/ignition cut off?
Is the warning light still flashing? Which one, the lock symbol?
Was the "diagnostic expert a Fiat person?
 
OP
OP
S

StiloRuS

New member
Joined
Oct 22, 2007
Messages
4
The diagnostic expert did not find any problems except the airbag and the locksmith was talking about ignition coil?. On the dash is says " Connection loose? along them lines and the key on the dash keeps flashing?
 

Deckchair5

Whaddya mean too old?
Joined
May 1, 2005
Messages
5,607
Location
Roman city Bath
Why would a locksmith worry about ignition coils?
Was the diagnostics expert Fiat based?
And answers to the other questions are........?
 
OP
OP
S

StiloRuS

New member
Joined
Oct 22, 2007
Messages
4
Hi, yesterday i played around with the d4 connector, the ring round the barrel, and my car started! This morning i tried starting the car again and it came up with the same problem! Car security failure.. connection loose!.. it says on the dash! I tried playing about with the ring around the barrel " D4 Connector " Can anyone shed some light on me please!
 
Top