Technical Ignition problem - P0683

gjorgievskivlatko

New member
Joined
Oct 7, 2021
Messages
2
Hi everyone, I own Fiat Sedici 1.9 D Multijet 4x4 2009, diesel engine (D19AA).
I am having some issues with the ignition of the car only when the car haven't been working for a while, for example, every morning. Every next start when the car is warm has no issues at all, it starts right away.
I've been to a mechanic to check this and he changed the glow plugs relay with a new one and says that everything is fine with the glow plugs.
I've also used Bardahl Common Rail Diesel Injector Cleaner on the mechanic suggestion to clean the injectors.
The car works a bit better now but the ignition problem still persists.
As you can see on the video, when I check diagnostic of the car by using the application SZ Viewer (I am not able to post links yet it can be found at: malykh . com/soft/sz-viewer) for android by using the OBD port, I am still getting error code P0683 (which means problem with the glow plugs).
So I am not sure now who should I trust ?
Any thoughts what could be issue ?
Have you used the app SZ Viewer ?
Can I trust the app SZ Viewer, is it reliable ?
And more important, do you have some idea what should be checked ?
Thank you and have a nice day.
 

Attachments

  • sedici_p0683.zip
    11.7 MB · Views: 0
  • VID_20211020_093001.mp4.zip
    17.4 MB · Views: 3
OP
OP
G

gjorgievskivlatko

New member
Joined
Oct 7, 2021
Messages
2
Update: After changed glow plugs relay and also the glow plugs, now it starts without any issues at all.
There is also no error code in the app anymore, the app works and is reliable.

This thread can be closed.
 
Top