Help!!!!

clarky95

New member
Joined
Sep 24, 2009
Messages
3
Help!!!! Really Urgent!!!!!

I have a 56 Grande Punto Sporting 1.4 - Love the car but all of a sudden today when i turn the engine on its just cutting out, if i put it in gear and get going its fine but when i come to traffic lights or have to stop its just cutting out, can anyone help!!! Please let me know what you think it is.

Much appreciated

D
 
Last edited:

JayZone

New member
Joined
Sep 11, 2009
Messages
50
Location
Wakefield
Re: Help!!!! Really Urgent!!!!!

A couple of thoughts:

- If you keep the revs high while at traffice lights does it still cut out? Might not be getting enough fuel when ideling.
- Have you checked the Battery/alternator to make sure one of these two is not failing

not sure if either helps but just points to consider.
 
OP
OP
C

clarky95

New member
Joined
Sep 24, 2009
Messages
3
Re: Help!!!! Really Urgent!!!!!

a couple of thoughts:

- if you keep the revs high while at traffice lights does it still cut out? Might not be getting enough fuel when ideling.
- have you checked the battery/alternator to make sure one of these two is not failing

not sure if either helps but just points to consider.

it does not cut out when the revs are high!!! Do you think it could be something to do with the fuel pump??
 

JayZone

New member
Joined
Sep 11, 2009
Messages
50
Location
Wakefield
Re: Help!!!! Really Urgent!!!!!

it does not cut out when the revs are high!!! Do you think it could be something to do with the fuel pump??
The area's i'd start with are (Bearing in mind i'm not a mechanic so just trying a logical approach)

- Try running some cleaner through with the petrol to make sure your injectors are clean,
- Get an amp meter on both the battery and Alternator. With a friend at wheel rev the engine and check what the readings are both at rest and when rev's are increased

It could be a pump issue but not sure of any easy way to test that although i'm sure someone on the forum would be able to help.

Also as an outside chance check your air filter and see if its blocked in any way.

Definately sounds like its not getting enough Air, Fuel, Power when sitting at low revs but thats only from a laymans prespective. It could equally be something relating to the engine management side in which case i wouldn't have a clue where to start lol.

Hope some of that rambling helps.
 
OP
OP
C

clarky95

New member
Joined
Sep 24, 2009
Messages
3
Re: Help!!!! Really Urgent!!!!!

The area's i'd start with are (Bearing in mind i'm not a mechanic so just trying a logical approach)

- Try running some cleaner through with the petrol to make sure your injectors are clean,
- Get an amp meter on both the battery and Alternator. With a friend at wheel rev the engine and check what the readings are both at rest and when rev's are increased

It could be a pump issue but not sure of any easy way to test that although i'm sure someone on the forum would be able to help.

Also as an outside chance check your air filter and see if its blocked in any way.

Definately sounds like its not getting enough Air, Fuel, Power when sitting at low revs but thats only from a laymans prespective. It could equally be something relating to the engine management side in which case i wouldn't have a clue where to start lol.

Hope some of that rambling helps.

Thanks so much, will keep you updated

D
 
Top