Technical Help with fiat 600D running

Currently reading:
Technical Help with fiat 600D running

Shepster998

New member
Joined
Feb 10, 2019
Messages
25
Hi all,
I have a 1965 600D - this is the nearest forum I could find for help! At the moment it's runing rough. It idles OK on the choke - when I press the accelerator the revs drop. Then when I take my foot off the accelerator the revs come up, so there is a delay. When it does rev, it sounds OK (i.e. not missing any cyclinders)


I've replaced the fuel pump, plugs, HT leads, new points, new distributor cap. I've cleaned out the carb and repalaced gaskets and seat. I've also tried a different coil. I've checked static timing.

The other thing I've noticed is that while it's idling, the generator light stays on. Could this be part of the problem?

Does anyone have any suggestions?

Rob
 

timmycm850

Active member
Joined
Feb 28, 2016
Messages
670
Hi Shepster

i would locate the idle jet on the carb and clean it, i know youve cleaned the carb but you must remove the idle jet screw and also pull it apart and blow up the inside of the holed end, this action is often missed, debris can often get jammed in the hole so you must be able to look through it and see through it.

Tim
 

timmycm850

Active member
Joined
Feb 28, 2016
Messages
670
Hi All

Not sure if you've made any progress on this as you've not posted back.

If your fuel is older than 3 months old then I would also put some fresh petrol in it(modern fuel doesn't age well).

Tim
 
Top