General Grande Punto window problem

Currently reading:
General Grande Punto window problem

RMVS

New member
Joined
Aug 11, 2022
Messages
2
Location
EH51 0AN
Hello,

Really struggling to find the issue with a Fiat Grande Punto 2006 reg passenger window.

The passenger window was not responding at all.

The fuse was broken and replaced and now I am getting something but the window motor is basically stuck on down. If you remove the motor from the regulator the motor runs constantly.

I have replaced the motor, the regulator and both switches and still the issue remains.

It surely cannot be a broken wire as the motor only has 2 wires going to it so if either of the 2 wires were broken it wouldn't receive power?

Is there a separate relay switch just for the passenger window?

Also to make matters more confusing the drivers window works fine.

Any help appreciated.

Thanks
 

DaveMR

Member
Joined
Mar 13, 2012
Messages
64
Location
Barnsley
It might be worth checking the wiring harness from the door to the body on both sides. Unplug the body connector and pull back the rubber sleeve. The wires end up really brittle and over time break due to the opening and closing of the doors.
 
Joined
Apr 27, 2011
Messages
31,238
Location
Near the M4
Hi

Yes the drivers door loom also has connections for the opposite doors window..and mirror

Mine behaved oddly..

This was the cause...
Chafed wiring at drivers door hinge
 
Last edited:
OP
OP
R

RMVS

New member
Joined
Aug 11, 2022
Messages
2
Location
EH51 0AN
It might be worth checking the wiring harness from the door to the body on both sides. Unplug the body connector and pull back the rubber sleeve. The wires end up really brittle and over time break due to the opening and closing of the doors.
Sorry for delay. Just to update as I hate when people do these threads and don't provide a conclusion. The issue was a broken wire on the drivers side. It was a broken wire to one of the switches therefore my theory of the motor still getting power so could not be a cable was wrong. Thanks for help!
 

YellowPuntoFiat

New member
Joined
Aug 16, 2018
Messages
23
It might be worth checking the wiring harness from the door to the body on both sides. Unplug the body connector and pull back the rubber sleeve. The wires end up really brittle and over time break due to the opening and closing of the doors.
I also have to thank you for this suggestion. I had already taken the door trim off and was going through the wiring. Opening up the rubber seal at the door hinge immediately exposed the problem. One wire broken and three others had their wiring exposed (driver side) and a broken wire on passenger side. I was even able to fix it before the rain came (window was open...)!

BTW - soldered the driver side and crimped the passenger side. Will let you know which one will break first... but crimping was much easier than soldering for me.
 
Top